您的位置:首页 > 其它

【HDU4576】Robot

2017-09-20 07:24 363 查看
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.



At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every
command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.

Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.

InputThere are multiple test cases.

Each test case contains several lines.

The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).

Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  

The input end with n=0,m=0,l=0,r=0. You should not process this test case.

OutputFor each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.Sample Input        3 1 1 2
1
5 2 4 4
1
2
0 0 0 0

Sample Output
0.5000
0.2500


题解


直接dp+滚动数组。


采用刷表法,dp[i][j]表示第i个操作到第j个数字的概率,用dp[i][j]更新dp[i+1][j+w]和dp[j+1][j-w],注意事项都在代码中标注。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=210;
double f[2][maxn];
int main(){
int n,m,l,r,w,now,last;
while(scanf("%d%d%d%d",&n,&m,&l,&r)!=EOF){
if(n==0&&m==0&&l==0&&r==0) break;//可能不是有0就停止,多次读入时注意
memset(f,0,sizeof(f));
f[0][0]=1;
now=1;
while(m--){
scanf("%d",&w);
w%=n;//可能一开始大于n
for(int j=0;j<n;j++)
f[now][j]=0;

for(int j=0;j<n;j++){//因为要转圈取模,所以只能从0开始符合规则,切记!!!
if(!f[now^1][j]) continue;
f[now][(w+j)%n]+=0.5*f[now^1][j];
f[now][(j-w+n)%n]+=0.5*f[now^1][j];
}
now^=1;
}
double ans=0;
for(int i=l;i<=r;i++)
ans+=f[now^1][i-1];

printf("%.4lf\n",ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  递推与dp