您的位置:首页 > 其它

POJ - 2309 BST —— lowbit

2017-09-19 23:33 519 查看
BST

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10348 Accepted: 6334
Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and
we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 



Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).
Output

There are N lines in total, the i-th of which contains the answer for the i-th query.
Sample Input
2
8
10

Sample Output
1 15
9 11


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#define max_ 100010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int main(int argc, char const *argv[])
{
int n;
cin>>n;
while(n--)
{
int k;
cin>>k;
int s= (k&(-k)) -1;
cout<<k-s<<" "<<k+s<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: