您的位置:首页 > 其它

【期望入门】【PoJ2096】【总结】

2017-09-19 17:55 232 查看


发现图包根本用不完系列

Collecting Bugs

Time Limit: 10000MS Memory Limit: 64000K

Total Submissions: 1485 Accepted: 647

Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.

Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria — Ivan should find at least one bug in each subsystem and at least one bug of each category.

Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It’s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan’s opinion about the reliability of the obsolete version.

A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.

Find an average time (in days of Ivan’s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan’s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

好吧我承认这是一道水题,但由此题入门期望再适合不过:

题目大意

有n种bug和s个系统,求发现在s个系统中,各个系统n中全部都出现 的概率天数;

设dp[i][j]为在i个系统中,各个系统j中全部都出现 的概率天数;

那么dp[s]
= 0,因为啥都没有的话0天便可以看出是肯定的;

而转移勒?

dp[i][j] 的转移便是把(所有可能情况 + 1)*他们各自转移过来的概率

【注】 此处加1代表是转移1步,过了一天

上述结论由下图



所以有一下结论:

【1】dp[i][j] = p1 * (dp[i][j] + 1) + p2 ( dp[i + 1][j] + 1) + p3 ( dp[i][j + 1] + 1) + p4 * (dp[i + 1][j + 1] + 1)

【2】dp[i][j] * (1 - p1) = p2 * dp[i + 1][j] + p3 * dp[i][j + 1] + p4 * dp[i + 1][j + 1] + (p1 + p2 + p3 + p4)

【3】dp[i][j] = (p2 * dp[i + 1][j] + p3 * dp[i][j + 1] + p4 * dp[i + 1][j + 1] + (p2 + p3 + p4 + p1)) / (1 - p1)

【注】p1 , p2 , p3 , p4代表概率

p1 = i * j / (n * s)

p2 = (s - i) * j / (n * s)

p3 = i * (n - j) / (n * s)

p4 = (s - i)* (n - j) / (n * s)

p1 + p2 + p3 + p4 = 1;

这里有一点需要注意:

由于概率是平均概率,所以等式【1】左右我们看到dp [i][j]是等价的,所以可以将其合并,不用过多的去细想:“dp [i][j]由dp [i][j]推来可以推无限遍那么咋搞啊?”的疑问;

那么这道题遍可以这样水过去了,废话少说,直接上代码

/*
dp[i][j] = p1 * dp[i][j] + p2 * dp[i + 1][j] + p3 * dp[i][j + 1] + p4 * dp[i + 1][j + 1]
dp[i][j] * (1 - p1) = p2 * dp[i + 1][j] + p3 * dp[i][j + 1] + p4 * dp[i + 1][j + 1]
dp[i][j] = (p2 * dp[i + 1][j] + p3 * dp[i][j + 1] + p4 * dp[i + 1][j + 1] + 1) / (1 - p1)
注意!!!这里加1是应为所以转移的概率之和为1,但有些情况下转移过来的情况的概率不一定为1,这哪是为概率之和

p1 = i * j / (n * s)
p2 = (s - i) * j / (n * s)
p3 = i * (n - j) / (n * s)
p4 = (s - i)* (n - j) / (n * s)

dp[i][j] = (dp[i+1][j] * (s - i) * j + dp[i][j+1] * (s - j)*i + dp[i+1][j+1]*(s - i)*(s - j) + n*s)/(n*s - i*j)
*/
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define M 1200
using namespace std;
int n , s;
double dp[M][M];
int main(){
while(scanf("%d%d",&n,&s) != EOF){
dp[s]
= 0;
for(int i = s ; i >= 0  ; --i)
for(int j = n ; j >= 0 ; --j){
if(i == s && j == n)continue;
dp[i][j] = (dp[i+1][j] * (s - i) * j + dp[i][j+1] * (n - j)*i + dp[i+1][j+1]*(s - i)*(n - j) + n * s )/(n*s - i*j);
}
printf("%.4f\n",dp[0][0]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: