您的位置:首页 > 其它

南阳oj 58 bfs入门

2017-09-19 17:21 239 查看
点击打开链接

最少步数

时间限制:3000 ms  |  内存限制:65535 KB

难度:4

描述
这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1

 1,0,0,1,0,0,1,0,1

 1,0,0,1,1,0,0,0,1

 1,0,1,0,1,1,0,1,1

 1,0,0,0,0,1,0,0,1

 1,1,0,1,0,1,0,0,1

 1,1,0,1,0,1,0,0,1

 1,1,0,1,0,0,0,0,1

 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入 第一行输入一个整数n(0<n<=100),表示有n组测试数据;

随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。 输出 输出最少走几步。 样例输入
2
3 1  5 7
3 1  6 7

样例输出
12
11


入门的bfs,当然也可以用dfs做。

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
struct node
{
int x,y,step;
}no,ne;
int map[9][9]={
1,1,1,1,1,1,1,1,1,
1,0,0,1,0,0,1,0,1,
1,0,0,1,1,0,0,0,1,
1,0,1,0,1,1,0,1,1,
1,0,0,0,0,1,0,0,1,
1,1,0,1,0,1,0,0,1,
1,1,0,1,0,1,0,0,1,
1,1,0,1,0,0,0,0,1,
1,1,1,1,1,1,1,1,1
};
int move[4][2]={1,0,-1,0,0,1,0,-1};
int tx,ty;
int vis[9][9];
void bfs(int x,int y)
{
queue<node>q;
no.x=x,no.y=y;
no.step=0;
q.push(no);
while(!q.empty())
{
no=q.front();
q.pop();
if(no.x==tx&&no.y==ty)
{
printf("%d\n",no.step);
return;
}
for(int i=0;i<4;i++)
{
ne.x=no.x+move[i][0];
ne.y=no.y+move[i][1];
ne.step=no.step+1;
if(ne.x<0||ne.x>=9||ne.y<0||ne.y>=9)
continue;
if(!vis[ne.x][ne.y]&&map[ne.x][ne.y]==0)
{
vis[ne.x][ne.y]=1;
q.push(ne);
}
}
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int x,y;
scanf("%d%d%d%d",&x,&y,&tx,&ty);
memset(vis,0,sizeof(vis));
bfs(x,y);
}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: