您的位置:首页 > 其它

hdu 1114 Piggy-Bank(完全背包)

2017-09-19 17:03 330 查看

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27504    Accepted Submission(s): 13899


[align=left]Problem Description[/align]
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

[align=left]Input[/align]
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

[align=left]Output[/align]
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

[align=left]Sample Input[/align]

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

 

[align=left]Sample Output[/align]

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题意:已知一个空存钱罐的准确重量,及它存满钱之后的准确重量;有n种硬币,每种硬币的重量及价值均不同,每种硬币的数量是无穷的;求存钱罐中最少已经放了多少钱,如果不能准确算出输出“This is impossible.”,否则输出“The minimum amount of money in the piggy-bank is X.”, X表示钱的价值,注意不要落下“.”;


很明显是个完全背包问题,但这道题问的是最小价值,我们只需小小变形一下就可以了,将动态转移方程中的max改成min;这时有一个问题,如果初始化dp为0,结果肯定为0,所以应把dp初始化为无穷,但是dp[0]要初始化为0;

现在奉上代码:

#include <iostream>
#include <algorithm>
#include <string.h>
#define INF 0x3f3f3f3f

using namespace std;

int dp[10005];
int main(){

int T;
cin >> T;
while(T--){
int E, F;
cin >> E >> F;
int N;
cin >> N;
int weight[505], val[505];
for(int i=1; i<=N; i++){
cin >> val[i] >> weight[i];
}
for(int i=1; i<=F-E; i++){
dp[i]=INF;
}
dp[0]=0; //dp[0]一定要初始化为0;
for(int i=1; i<=N; i++){
for(int j=weight[i]; j<=F-E; j++){
dp[j]=min(dp[j], dp[j-weight[i]]+val[i]);
}
}
if(dp[F-E]==INF) cout << "This is impossible.\n";
else cout << "The minimum amount of money in the piggy-bank is " << dp[F-E] << ".\n";
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: