您的位置:首页 > 其它

HDU-1686 - Oulipo - KMP

2017-09-19 16:21 471 查看

链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=1686

题目:

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

题意:

  给你两个字符串A和B,让你求出A在B中出现的次数。

思路:

  直接跑裸KMP,稍微修改一下就可以。

实现:

#include <bits/stdc++.h>
using namespace std;
const int maxn = int(2e7)+7;
char str[maxn], p[maxn];
int Next[maxn], n, m, t;
void GetNext() {
Next[0] = 0;
for(int i = 1, j = 0 ; i < m ; i++) {
while(j > 0 && p[i] != p[j]) j = Next[j-1];
if(p[i] == p[j]) j++;
Next[i] = j;
}
}
int KMP() {
int cnt = 0;
GetNext();
for(int i = 0, j = 0 ; i < n ; i++) {
while(j > 0 && p[j] != str[i]) j = Next[j-1];
if(p[j] == str[i]) j++;
if(j == m) cnt++;
}
return cnt;
}
int main() {
scanf("%d", &t);
while(t--) {
scanf(" %s %s", p, str);
n = int(strlen(str)), m = int(strlen(p));
printf("%d\n", KMP());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp