您的位置:首页 > 产品设计 > UI/UE

HDU 1242 Rescue(DFS入门)

2017-09-19 08:22 549 查看


Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32571    Accepted Submission(s): 11382


Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

 

Sample Output

13

 
#include <stdio.h>
char map[500][500];
int visit[500][500];
int n,m,min;
void dfs(int x,int y,int len)
{
if(x<0||y<0||x>=n||y>=m) return;
if(map[x][y]=='#')return;
if(len>=min)return;
if(visit[x][y])return;
if(map[x][y]=='r')
{
if(min>len)
{
min=len;
return;
}
}
if(map[x][y]=='x')
{
len=len+1;
}
visit[x][y]=1;
dfs(x+1,y,len+1);
dfs(x-1,y,len+1);
dfs(x,y+1,len+1);
dfs(x,y-1,len+1);
visit[x][y]=0;
}
int main(int argc, char *argv[])
{
while(scanf("%d %d",&n,&m)!=EOF)
{
getchar();
int i,j,len;
int flagx,flagy;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='a')
{
flagx=i;
flagy=j;
}
}
getchar();
}
min=999999;
dfs(flagx,flagy,0);
if(min==999999)
printf("Poor ANGEL has to stay in the prison all his life.\n" );
else
printf("%d\n",min);
}
return 0;
}

关于是否需要用标记的问题:1.每一个点都是四方搜索的如果用过的点不标记的话则会向后开始回溯,其他的回溯同理需要标记
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: