您的位置:首页 > 其它

hdu 6208 The Dominator of Strings 后缀自动机 LCS

2017-09-18 23:42 387 查看



The Dominator of Strings

Time Limit: 3000/3000 MS (Java/Others)    Memory
Limit: 65535/32768 K (Java/Others)

Total Submission(s): 668    Accepted Submission(s): 197

Problem Description

Here you have a set of strings. A dominator is a string of the set dominating all strings else. The string S is
dominated by T if S is
a substring of T.

 

Input

The input contains several test cases and the first line provides the total number of cases.

For each test case, the first line contains an integer N indicating
the size of the set.

Each of the following N lines
describes a string of the set in lowercase.

The total length of strings in each case has the limit of 100000.

The limit is 30MB for the input file.

 

Output

For each test case, output a dominator if exist, or No if not.

 

Sample Input

3
10
you
better
worse
richer
poorer
sickness
health
death
faithfulness
youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
5
abc
cde
abcde
abcde
bcde
3
aaaaa
aaaab
aaaac

 

Sample Output

youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
abcde
No

 
题意:从以上的字符串中找到一个字符串,然后其他所
从以上的字符串中找到一个字符串,然后其他所有的字符串都是它的子串。
找最长的len,记录在哪里 lcs就好了。
//china no.1
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <vector>
#include <iostream>
#include <string>
#include <map>
#include <stack>
#include <cstring>
#include <queue>
#include <list>
#include <stdio.h>
#include <set>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <iomanip>
#include <cctype>
#include <sstream>
#include <functional>
#include <stdlib.h>
#include <time.h>
#include <bitset>
using namespace std;

#define pi acos(-1)
#define s_1(x) scanf("%d",&x)
#define s_2(x,y) scanf("%d%d",&x,&y)
#define s_3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define PI acos(-1)
#define endl '\n'
#define srand() srand(time(0));
#define me(x,y) memset(x,y,sizeof(x));
#define foreach(it,a) for(__typeof((a).begin()) it=(a).begin();it!=(a).end();it++)
#define close() ios::sync_with_stdio(0); cin.tie(0);
#define FOR(x,n,i) for(int i=x;i<=n;i++)
#define FOr(x,n,i) for(int i=x;i<n;i++)
#define fOR(n,x,i) for(int i=n;i>=x;i--)
#define fOr(n,x,i) for(int i=n;i>x;i--)
#define W while
#define sgn(x) ((x) < 0 ? -1 : (x) > 0)
#define bug printf("***********\n");
#define db double
#define ll long long
#define mp make_pair
#define pb push_back
typedef pair<long long int,long long int> ii;
typedef long long LL;
const int INF=0x3f3f3f3f;
const LL LINF=0x3f3f3f3f3f3f3f3fLL;
const int dx[]={-1,0,1,0,1,-1,-1,1};
const int dy[]={0,1,0,-1,-1,1,-1,1};
const int maxn=1e5+10;
const int maxx=600005;
const double EPS=1e-8;
const double eps=1e-8;
const int mod=1e9+7;
template<class T>inline T min(T a,T b,T c) { return min(min(a,b),c);}
template<class T>inline T max(T a,T b,T c) { return max(max(a,b),c);}
template<class T>inline T min(T a,T b,T c,T d) { return min(min(a,b),min(c,d));}
template<class T>inline T max(T a,T b,T c,T d) { return max(max(a,b),max(c,d));}
template <class T>
inline bool scan_d(T &ret){char c;int sgn;if (c = getchar(), c == EOF){return 0;}
while (c != '-' && (c < '0' || c > '9')){c = getchar();}sgn = (c == '-') ? -1 : 1;ret = (c == '-') ? 0 : (c - '0');
while (c = getchar(), c >= '0' && c <= '9'){ret = ret * 10 + (c - '0');}ret *= sgn;return 1;}

inline bool scan_lf(double &num){char in;double Dec=0.1;bool IsN=false,IsD=false;in=getchar();if(in==EOF) return false;
while(in!='-'&&in!='.'&&(in<'0'||in>'9'))in=getchar();if(in=='-'){IsN=true;num=0;}else if(in=='.'){IsD=true;num=0;}
else num=in-'0';if(!IsD){while(in=getchar(),in>='0'&&in<='9'){num*=10;num+=in-'0';}}
if(in!='.'){if(IsN) num=-num;return true;}else{while(in=getchar(),in>='0'&&in<='9'){num+=Dec*(in-'0');Dec*=0.1;}}
if(IsN) num=-num;return true;}

void Out(LL a){if(a < 0) { putchar('-'); a = -a; }if(a >= 10) Out(a / 10);putchar(a % 10 + '0');}
void print(LL a){ Out(a),puts("");}
//freopen( "in.txt" , "r" , stdin );
//freopen( "data.txt" , "w" , stdout );
//cerr << "run time is " << clock() << endl;

int root,last;
int tots;  //总结点
int l;  //字符串长度

struct node
{
int st,len;
}Q[maxn*2];
int pos;
struct sam_node
{
int fa,son[26];
int len;
void init(int _len)
{
len = _len;
fa = -1;
memset(son,-1,sizeof(son));
}
}t[maxn*2];

void sam_init()
{
tots = 0;
root = last = 0;
t[tots].init(0);
}

void extend(int w)
{
int p=last;
int np=++tots;t[tots].init(t[p].len+1);
int q,nq;
while(p!=-1&&t[p].son[w]==-1){t[p].son[w]=np;p=t[p].fa;}
if (p==-1) t[np].fa=root;
else
{
q=t[p].son[w];
if (t[p].len+1==t[q].len){t[np].fa=q;}
else
{
nq=++tots;t[nq].init(0);
t[nq]=t[q];
t[nq].len=t[p].len+1;
t[q].fa=nq;t[np].fa=nq;
while(p!=-1&&t[p].son[w]==q){t[p].son[w]=nq;p=t[p].fa;}
}
}
last=np;
}

int w[maxn], r[maxn*2];

void topsort()
{
for(int i = 0; i <= l; ++i) w[i] = 0;
for(int i = 1; i <= tots; ++i) w[t[i].len]++;
for(int i = 1; i <= l; ++i) w[i] += w[i-1];
for(int i = tots; i >= 1; --i) r[w[t[i].len]--] = i;
r[0] = 0;
}

//int dp[maxn*2];
char s[maxn*2];

int work(char *T)
{
int i,now=root,ind,tl=0;
int ret=0;
for(char *p=T;*p;++p)
{
ind=*p-'a';
while(now!=-1&&t[now].son[ind]==-1)
{
now=t[now].fa;
if (now!=-1) tl=t[now].len;
}
if (now==-1) {now=root;tl=0;}
else
{
now=t[now].son[ind];
tl++;
ret=max(ret,tl);
}
}
return ret;
}

int T,n;
int check()
{
FOr(0,n,i)
{
if(i!=pos)
{
if(work(Q[i].st+s)<Q[i].len)
return 1;
}
}
return 0;
}
int main()
{
s_1(T);
W(T--)
{
Q[0].st=0;
sam_init();
pos=0;
s_1(n);
FOr(0,n,i)
{
char* p=s+Q[i].st;
scanf("%s",p);
Q[i].len=strlen(p);
if(Q[i].len>Q[pos].len) pos=i;
Q[i+1].st=Q[i].st+Q[i].len+1;
}
for(char* p=Q[pos].st+s; *p; ++p)
extend(*p-'a');
if(check())
puts("No");
else puts(Q[pos].st+s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: