您的位置:首页 > 其它

HDU 1061 Rightmost Digit

2017-09-18 20:31 567 查看

Rightmost Digit

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58270    Accepted Submission(s): 22084

[/align]

[align=left]Problem Description[/align]
Given a positive integer N, you should output the most right digit of N^N.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

[align=left]Output[/align]
For each test case, you should output the rightmost digit of N^N.

 

[align=left]Sample Input[/align]

2
3
4

 

[align=left]Sample Output[/align]
7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.就是找一下规律,思路是这样的:末位数      相乘后的末位数
1           1
2           4   8   6   2
3           9   7   1   3
4           6   4
5           5
6           6
7            9   3   1   7
8            4   2   6   8
9            1   9
0            0
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
int T,n,sd,digit;
scanf("%d",&T);
while(T--)
{
if(scanf("%d",&n) != EOF)
{
sd = n%10;
if(sd==0 || sd==1 || sd==5 || sd==6 || sd==9)
digit = sd;
else if(sd == 2 || sd == 8)
{
if(n%4 == 0)
sd = 6;
else
sd = 4;
}
else if(sd == 3)
{
if(n%4 == 1)
sd = 3;
else
sd = 7;
}
else if(sd == 4)
{
sd = 6;
}
else{
if(n%4 == 1)
sd = 7;
else
sd = 3;
}
printf("%d\n",sd);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息