您的位置:首页 > 其它

HDU 2095 find your present (2)

2017-09-18 20:18 477 查看

find your present (2)

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24959    Accepted Submission(s): 9894

[/align]

[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card
number of 3, because 3 is the number that different from all the others.
 

[align=left]Input[/align]
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.
 

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0

 

[align=left]Sample Output[/align]

3
2

HintHint
use scanf to avoid Time Limit Exceeded
这个题用一般套路很容易超时,所以这里用一个new方法,异或举一个例子。
   如 数据  1 2 3 2 1   
   先让result=0
   那么可以看成是  result^1^2^3^2^1
        交换律     result^1^1^2^2^3
       很明显      1^1 和  2^2 都为 0
       所以最后得    result^3 =0^3 =3(二进制 101)怎样很容易理解吧

#include<stdio.h>
int main()
{
int i,k,n,s;
while(scanf("%d",&n),n)
{
s=0;
for(i=0;i<n;i++)
{
scanf("%d",&k);
s^=k;
}
printf("%d\n",s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息