您的位置:首页 > 其它

【模板练习——AC自动机】Keywords Search HDU - 2222

2017-09-18 11:51 579 查看
Think:

1题意:询问在目标串中出现几个模式串

Keywords Search HDU - 2222

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs


Sample Output

3


以下为Accepted代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int pat_len = 501400;/*why???*/
const int tar_len = 1001400;

struct Trie{
int next[pat_len][26], fail[pat_len], end[pat_len];
int root, L;
int new_node(){
for(int i = 0; i < 26; i++)
next[L][i] = -1;
end[L++] = 0;
return L-1;
}
void Init(){
L = 0;
root = new_node();
}
void Insert(char buf[]){
int len = strlen(buf);
int now = root;
for(int i = 0; i < len; i++){
if(next[now][buf[i]-'a'] == -1){
next[now][buf[i]-'a'] = new_node();
}
now = next[now][buf[i]-'a'];
}
end[now]++;
}
void build(){
queue <int> Q;
fail[root] = root;
for(int i = 0; i < 26; i++){
if(next[root][i] == -1)
next[root][i] = root;
else {
fail[next[root][i]] = root;
Q.push(next[root][i]);
}
}
while(!Q.empty()){
int now = Q.front();
Q.pop();
for(int i = 0; i < 26; i++){
if(next[now][i] == -1)
next[now][i] = next[fail[now]][i];
else {
fail[next[now][i]] = next[fail[now]][i];
Q.push(next[now][i]);
}
}
}
}
int query(char buf[]){
int len = strlen(buf);
int now = root;
int res = 0;
for(int i = 0; i < len; i++){
now = next[now][buf[i]-'a'];
int temp = now;
while(temp != root){
res += end[temp];
end[temp] = 0;
temp = fail[temp];
}
}
return res;
}
};

char buf[tar_len];
Trie ac;

int main(){
int T, n;
scanf("%d", &T);
while(T--){
scanf("%d", &n);
ac.Init();
for(int i = 0; i < n; i++){
scanf("%s", buf);
ac.Insert(buf);
}
ac.build();
scanf("%s", buf);
printf("%d\n", ac.query(buf));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息