您的位置:首页 > 其它

1134. Vertex Cover (25)

2017-09-17 21:47 429 查看


1134. Vertex Cover (25)

时间限制

600 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes
an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] ... v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line "Yes" if the set is a vertex cover, or "No" if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:
No
Yes
Yes
No
No


实力不够

实力不够

实力不够

一开始用邻接矩阵写,结果内存超了。。。

后来用set做,erase 相当于删边 ,结束的时候若还有边,则size不为零,不满足要求。考试的时候过了,怎么现在最后2点超时了。。。

#include<stdio.h>
#include<vector>
#include<set>
using namespace std;
set<int>adj[10010];
set<int>tempadj[10010];
vector<int>dele;
void init(int n){
int i;
for(i=0;i<n;i++){
tempadj[i]=adj[i];
}
}
int main(){
int n,m,k,i,j,c1,c2,num,z;
scanf("%d %d",&n,&m);
for(i=0;i<m;i++){
scanf("%d %d",&c1,&c2);
adj[c1].insert(c2);
adj[c2].insert(c1);
}
scanf("%d",&k);
for(i=0;i<k;i++){
scanf("%d",&num);
init(n);
dele.clear();
for(j=0;j<num;j++){
scanf("%d",&c1);
set<int>::iterator it=tempadj[c1].begin();
for(;it!=tempadj[c1].end();it++){
int next=*it;
tempadj[next].erase(c1);
dele.push_back(next);
}
for(z=0;z<dele.size();z++){
tempadj[c1].erase(dele[z]);
}
}
int flag=1;
for(j=0;j<n;j++){
if(tempadj[j].size()!=0){
flag=0;break;
}
}
if(flag){
printf("Yes\n");
}
else{
printf("No\n");
}
}
}


参看了别人的博客

#include<stdio.h>
#include<vector>
using namespace std;
vector<int>adj[10010];
vector<int>temp;
int visit[10010];
void init(int n){
int i;
for(i=0;i<n;i++){
visit[i]=0;
}
}
int main(){
int n,m,i,j,c1,c2,k,num,z;
scanf("%d %d",&n,&m);
for(i=0;i<m;i++){
scanf("%d %d",&c1,&c2);
adj[c1].push_back(c2);
adj[c2].push_back(c1);
}
scanf("%d",&k);
for(i=0;i<k;i++){
scanf("%d",&num);
temp.clear();
init(n);
for(j=0;j<num;j++){
scanf("%d",&c1);
temp.push_back(c1);
}
int cou=0;
for(j=0;j<temp.size();j++){
for(z=0;z<adj[temp[j]].size();z++){
int next=adj[temp[j]][z];
if(visit[next]==0){
cou++;
}
}
visit[temp[j]]=1;
}
if(cou==m){
printf("Yes\n");
}
else{
printf("No\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: