您的位置:首页 > 其它

顺序表应用5:有序顺序表归并

2017-09-17 09:16 113 查看
Problem Description

已知顺序表A与B是两个有序的顺序表,其中存放的数据元素皆为普通整型,将A与B表归并为C表,要求C表包含了A、B表里所有元素,并且C表仍然保持有序。

Input

输入分为三行:

第一行输入m、n(1<=m,n<=10000)的值,即为表A、B的元素个数;

第二行输入m个有序的整数,即为表A的每一个元素;

第三行输入n个有序的整数,即为表B的每一个元素;

Output

输出为一行,即将表A、B合并为表C后,依次输出表C所存放的元素。

Example Input

5 3

1 3 5 6 9

2 4 10

Example Output

1 2 3 4 5 6 9 10

#include<stdio.h>
#include<stdlib.h>
typedef int  ElemType ;
#define LIST_INIT_SIZE 20010
typedef struct
{
ElemType *elem;
int length;
int listsize;
}Sqlist;
void Initial_Sq(Sqlist &L)
{
L.elem = (ElemType*)malloc(LIST_INIT_SIZE*sizeof(ElemType));
L.length = 0;
L.listsize = LIST_INIT_SIZE;
}
void MergeList(Sqlist La,Sqlist Lb,Sqlist &Lc)
{
int i = 0 ,j = 0,k = -1 ;
for(;i<La.length&&j<Lb.length;)
{
if(La.elem[i]>Lb.elem[j])
{
Lc.elem[++k] = Lb.elem[j];
j++;
}
else
{
Lc.elem[++k] = La.elem[i];
i++;
}
}
if(i<La.length)
{
for(;i<La.length;i++)
Lc.elem[++k] = La.elem[i];
}
else if(j<Lb.length)
{
for(;j<Lb.length;j++)
Lc.elem[++k] = Lb.elem[j];
}
Lc.length = k+1;
}
int main()
{
int n , m, i,j ;
Sqlist La,Lb,Lc;
Initial_Sq(La);
Initial_Sq(Lb);
Initial_Sq(Lc);
scanf("%d %d",&m,&n);
La.length = m;
Lb.length = n;
Lc.length = m+n;
for(i = 0;i<La.length;i++)
scanf("%d",&La.elem[i]);
for(j = 0;j<Lb.length;j++)
scanf("%d",&Lb.elem[j]);
MergeList(La,Lb,Lc);
for(i = 0;i<Lc.length-1;i++)
printf("%d ",Lc.elem[i]);
printf("%d\n",Lc.elem[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: