您的位置:首页 > 其它

PAT甲级 1002. A+B for Polynomials (25)

2017-09-16 15:15 756 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

#include <iostream>

using namespace std;

int main() {
int n, m;
float c[1001] = { 0 };
cin >> n;
for (int i = 0; i < n; i++) {
float t;
cin >> m >> t;
c[m] += t;
}
cin >> n;
for (int i = 0; i < n; i++) {
float t;
cin >> m >> t;
c[m] += t;
}
int cnt = 0;
for (int i = 0; i <= 1000; i++) {
if (c[i] != 0)
cnt++;
}
cout << cnt;
for (int i = 1000; i >= 0; i--) {
if (c[i] != 0)
printf(" %d %.1f", i, c[i]); //这里是个出错点,如果用cout<<" "<<i<<" "<<c[i];有部分示例不通过
//可能是因为0要输出成0.0吧
}
cout << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: