您的位置:首页 > 其它

poj2184(01背包变形)

2017-09-15 17:57 295 查看

Cow Exhibition

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14108 Accepted: 5728
Description
"Fat and docile, big and dumb, they look so stupid, they aren't much

fun..."

- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output
8

Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF

= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value

of TS+TF to 10, but the new value of TF would be negative, so it is not

allowed.

//01背包变形。把Si当作容量,Ti做重量。因为容量不能是负的所以把所有的都加1000移到0的右边dp
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f
using namespace std;
int a[105],b[105];
int maxx=210000,mid=10000;
int dp[210000];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<=maxx;i++)
{
dp[i]=-inf;
}
dp[mid]=0;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i],&b[i]);
}
for(int i=1;i<=n;i++)
{
if(a[i]>0)
{
for(int j=maxx-1;j>=a[i];j--)
dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
}
else
{
for(int j=0;j<=maxx+a[i];j++)
dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
}
}
int ans=0;
for(int i=mid;i<maxx;i++)
{
if(dp[i]>0&&(dp[i]+(i-mid)>ans))
ans=dp[i]+i-mid;
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: