您的位置:首页 > 其它

HDOJ 1536 S-NIM SG函数

2017-09-14 17:10 211 查看
传送门http://acm.hdu.edu.cn/showproblem.php?pid=1536

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8427    Accepted Submission(s): 3532


[align=left]Problem Description[/align]
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.
 

[align=left]Input[/align]
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0
< m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by
a 0 on a line of its own.
 

[align=left]Output[/align]
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after ea
4000
ch test case.

 

[align=left]Sample Input[/align]

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

 

[align=left]Sample Output[/align]

LWW
WWL

 

[align=left]Source[/align]
Norgesmesterskapet 2004
 

继续练手。我写的第一版,超时。想来原因是mex函数每一层都去计算,有大量无用的工作

#include <iostream>
#include<stdio.h>
#include<queue>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<set>
#include<deque>
#include<queue>
#include<vector>
#include<map>
using namespace std;

int limit[10005];
int sg[10005];
int mark[10005];
char ans[10005];

int mex(int n,int tmp)
{
//memset(sg,0,sizeof(sg));
for(int i=1;i<=tmp;i++)
{
memset(mark,0,sizeof(mark));
for(int j=0;j<n;j++)
{
if(i-limit[j]<0) break;
mark[sg[i-limit[j]]]++;
}
int p=0;
while(mark[p]!=0) p++;
sg[i]=p;
}
return sg[tmp];
}

int main()
{
int n;
while(1){
cin>>n;
int ppp;
if(n==0) break;
for(int i=0;i<n;i++)
//cin>>limit[i];
scanf("%d",&limit[i]);
sort(limit,limit+n);
int num;
ppp=0;
cin>>num;
for(int i=0;i<num;i++){
int x;
cin>>x;
int sum=0;
for(int j=0;j<x;j++)
{
int tmp;
scanf("%d",&tmp);
sum^=judge(n,tmp);
}

if(sum==0) ans[ppp++]='L';
else ans[ppp++]='W';
}
for(int i=0;i<ppp;i++)
printf("%c",ans[i]);
cout<<endl;

}

return 0;
}


第二份代码,AC喽·~

#include <iostream>
#include<stdio.h>
#include<queue>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<set>
#include<deque>
#include<queue>
#include<vector>
#include<map>
using namespace std;

int limit[10005];
int sg[10005];
//char ans[10005];

int mex(int n,int tmp)
{
if(sg[tmp]!=-1) return sg[tmp];
int mark[1005]={0};
for(int j=0;j<n;++j)
{
if(tmp-limit[j]<0) break;
if(sg[tmp-limit[j]]==-1) mex(n,tmp-limit[j]);
mark[sg[tmp-limit[j]]]++;
}
int p=0;
while(mark[p]!=0) ++p;
sg[tmp]=p;
return p;
}

int main()
{
int n;
while(scanf("%d",&n),n){
//cin>>n;
int ppp;
if(n==0) break;
for(int i=0;i<n;i++)
//cin>>limit[i];
scanf("%d",&limit[i]);
sort(limit,limit+n);
int num;
ppp=0;
memset(sg,-1,sizeof(sg));     //这个一定要放这里!!之前一直超时就是放下面循环里了
cin>>num;
for(int i=0;i<num;i++)
{
int x;
cin>>x;
int sum=0;
for(int j=0;j<x;j++)
{
int tmp;
scanf("%d",&tmp);
int zz=mex(n,tmp);
sum=sum^zz;
}
if(sum==0) printf("L");
else printf("W");
}
printf("\n");
}

//system("pause");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: