您的位置:首页 > 其它

FZU - 2150 Fire Game —— BFS

2017-09-14 15:24 483 查看

 Problem 2150                            Fire Game

Accept: 2713    Submit: 9264

Time Limit: 1000 mSec    Memory Limit : 32768 KB



 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids
which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x,
y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted
in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.



 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass
in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10



 Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.



 Sample Input

4

3 3

.#.

###

.#.

3 3

.#.

#.#

.#.

3 3

...

#.#

...

3 3

###

..#

#.#



 Sample Output

Case 1: 1

Case 2: -1

Case 3: 0

Case 4: 2

题意:有一块n*m的空地 #表示草地 是可以燃烧的地方 开始时在两块草地上同时放火 火可以朝向四个方向蔓延 问最快能几秒把所有的草全都烧完 不能全部烧完就输出-1 

思路:输入时记录下所有的草地 枚举其中任意两块 宽搜即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <vector>
#define max 12
using namespace std;
char map[max][max];
bool vis[max][max];
int t,n,m,flag=0,sum=0,tim=0,minn=9999999,s,f=0;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
struct point
{
int x,y,time;
} z,zz;
vector<point>v;
queue<point>q;
int bfs()
{
while(q.size())
{
z=q.front();
q.pop();
for(int k=0;k<4;k++)
{
int tx=z.x+dir[k][0];
int ty=z.y+dir[k][1];
if(tx>=1&&ty>=1&&tx<=n&&ty<=m)
{
if(map[tx][ty]=='#'&&vis[tx][ty]==false)
{
zz.x=tx;
zz.y=ty;
zz.time=z.time+1;
//cout<<zz.time<<endl;
q.push(zz);
vis[tx][ty]=true;
s--;
if(s==0)
{
flag=1;
return zz.time;
}
}
}
}
}
}
int main()
{
cin>>t;
for(int r=1;r<=t;r++)
{
memset(vis,false,sizeof(vis));
sum=0;
f=0;
flag=0;
minn=9999999;
v.clear();
cin>>n>>m;
int i,j;
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
cin>>map[i][j];
if(map[i][j]=='#')
{
z.x=i;
z.y=j;
z.time=0;
v.push_back(z);
sum++;
}
}
}
if(sum==1||sum==2)
{
printf("Case %d: 0\n",r);
continue;
}
for(i=0;i<v.size();i++)
{
for(j=0;j<v.size();j++)
{
memset(vis,false,sizeof(vis));
flag=0;

while(q.size())
q.pop();
vis[v[i].x][v[i].y]=true;
vis[v[j].x][v[j].y]=true;
if(i!=j)
{
q.push(v[i]);
q.push(v[j]);
}
else
{
q.push(v[i]);
}
if(i!=j)
s=sum-2;
else
s=sum-1;
tim=bfs();
if(flag)
f=1;
if(flag&&tim<minn)
minn=tim;
memset(vis,false,sizeof(vis));

}
}
if(f)
printf("Case %d: %d\n",r,minn);
else
printf("Case %d: -1\n",r);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: