您的位置:首页 > 其它

HDU - 3336 Count the string(KMP+DP)

2017-09-14 12:14 453 查看


Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11320    Accepted Submission(s): 5276


Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

 

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

Output
4000

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

Sample Input

1
4
abab

 

Sample Output

6

 

Author

foreverlin@HNU

 

Source

HDOJ Monthly Contest – 2010.03.06

 

Recommend

lcy

 

Statistic | Submit | Discuss | Note

题意:给出主串,以主串的所有前缀为模式串问所有模式串匹配次数之和;
#include <bits/stdc++.h>
using namespace std;

const int N = 200000 + 10, Mod = 10007;
int t, n;
char a
;
int nex
, dp
;

void get_nex(){
int i = 0, j = -1;
nex[0] = -1;
while(i < n){
if(j == -1 || a[i] == a[j]){
i++, j++;
nex[i] = j;
}
else j = nex[j];
}
}

int main(){
scanf("%d", &t);
while(t--){
memset(dp, 0, sizeof dp);
scanf("%d", &n);
scanf("%s", a);
get_nex();
int ans = 0;
for(int i = 1; i <= n; i++){
dp[i] = dp[nex[i]]+1;
ans += dp[i];
ans %= Mod;
}
printf("%d\n", ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: