您的位置:首页 > 其它

[bzoj1606][Usaco2008 Dec]Hay For Sale 购买干草

2017-09-14 10:17 489 查看

1606: [Usaco2008 Dec]Hay For Sale 购买干草

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 1365  Solved: 1009

[Submit][Status][Discuss]

Description

    约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草.  顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,
他最多可以运回多少体积的干草呢?

Input

    第1行输入C和H,之后H行一行输入一个Vi.

Output

 
    最多的可买干草体积.

Sample Input

7 3 //总体积为7,用3个物品来背包

2

6

5

The wagon holds 7 volumetric units; three bales are offered for sale with

volumes of 2, 6, and 5 units, respectively.

Sample Output

7 //最大可以背出来的体积

HINT

Buying the two smaller bales fills the wagon.

Source

开始50000*50000写错一维排在倒数第二页,还以为写的是暴力
#include<bits/stdc++.h>
using namespace std;
int c,h,v[5005],f[50005];
int main(){
scanf("%d%d", &c, &h); f[0] = 1;
for( int i = 1; i <= h; i++ ) scanf("%d", &v[i]);
for( int i = 1; i <= h; i++ )
for( int j = c; j >= v[i]; j-- )
f[j] |= f[j-v[i]];
for( int i = c; i >= 0; i-- ) if( f[i] ) { printf("%d\n", i); return 0; }
}
/*
7 3
2
6
5
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: