您的位置:首页 > 其它

【HDU6199 2017 ACM ICPC Asia Regional Shenyang Online F】【博弈 DP】gems gems gems 双人从左侧拿宝石 每次拿相同或加一的最小差值

2017-09-13 09:47 369 查看


gems gems gems

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1172    Accepted Submission(s): 242


Problem Description

Now there are n gems,
each of which has its own value. Alice and Bob play a game with these n gems.

They place the gems in a row and decide to take turns to take gems from left to right. 

Alice goes first and takes 1 or 2 gems from the left. After that, on each turn a player can take k or k+1 gems
if the other player takes k gems
in the previous turn. The game ends when there are no gems left or the current player can't take k or k+1 gems.

Your task is to determine the difference between the total value of gems Alice took and Bob took. Assume both players play optimally. Alice wants to maximize the difference while Bob wants to minimize it.

 

Input

The first line contains an integer T (1≤T≤10),
the number of the test cases. 

For each test case:

the first line contains a numbers n (1≤n≤20000);

the second line contains n numbers: V1,V2…Vn.
(−100000≤Vi≤100000)

 

Output

For each test case, print a single number in a line: the difference between the total value of gems Alice took and the total value of gems Bob took.

 

Sample Input

1
3
1 3 2

 

Sample Output

4

 

Source

2017 ACM/ICPC Asia Regional Shenyang Online

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre() { freopen("c://test//input.in", "r", stdin); freopen("c://test//output.out", "w", stdout); }
#define MS(x, y) memset(x, y, sizeof(x))
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1, class T2>inline void gmax(T1 &a, T2 b) { if (b > a)a = b; }
template <class T1, class T2>inline void gmin(T1 &a, T2 b) { if (b < a)a = b; }
const int N = 2e4 + 10, M = 0, Z = 1e9 + 7, inf = 0x3f3f3f3f;
template <class T1, class T2>inline void gadd(T1 &a, T2 b) { a = (a + b) % Z; }
int casenum, casei;
int n;
int sum
;
int v
;
int f
[202];
int main()
{
scanf("%d", &casenum);
for (casei = 1; casei <= casenum; ++casei)
{
scanf("%d", &n);
for (int i = n; i >= 1; --i)scanf("%d", &v[i]);
for (int i = 1; i <= n; ++i)sum[i] = sum[i - 1] + v[i];

//设m为最大能取到的数量,则有(1+m)*m<=n*2,得到m^2+m<=n*2,得到m<sqrt(n*2)
int m = sqrt(n * 2);
while ((1 + m) * m > n * 2)--m;

for (int i = 1; i <= n; ++i)//枚举当前还剩下几个
{
int top = min(i, m);
for (int j = 1; j <= top; ++j)//枚举上一轮的人拿了多少个
{
f[i][j] = -2e9;
gmax(f[i][j], (sum[i] - sum[i - j]) - f[i - j][j]); //这一轮拿一样多
if(i > j)gmax(f[i][j], (sum[i] - sum[i - j - 1]) - f[i - j - 1][j + 1]); //这一轮多拿一个
}
}
printf("%d\n", f
[1]);
}
return 0;
}
/*
【题意】
有n(2e4)个宝石
两个人轮流从左侧取宝石,Alice先手,首轮取1个或2个宝石,
如果上一轮取了k个宝石,则这一轮只能取k或k+1个宝石。
一旦不能再取宝石就结束。
双方都希望自己拿到的宝石数比对方尽可能多。
问你,先手比后手多拿的最大宝石数。

【分析】
我们用f[i][j]表示剩下i和宝石没取,上个人取了j个宝石,先手所能获得的最大宝石价值差。
则我们此时,如果可i>=j(或i>=j+1),则可以选择拿j或j+1个宝石,对应着f[i-k][k]的后继,有gmax(f[i][j], (sum[i]-sum[i-k]) - f[i-k][k])

1,所有非法状态,都以0为初始值即可
2,每个v最多使得绝对值偏差1e5,所以int即可保存所有状态

【时间复杂度&&优化】
O(nsqrt(n))

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐