您的位置:首页 > 其它

hdu 2586 LCA在线算法

2017-09-13 09:03 134 查看
Problem Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always
unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

 

Input

First line is a single integer T(T<=10), indicating the number of test cases.

  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road
connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.

  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

 

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

 

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

 

Sample Output

10
25
100
100
题意:给定一棵树,让我们球两点之间的距离
思路:ans=dir(x)+dir(y)-2*dir(lca(x,y))
ac代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
using namespace std;
const int maxn=40010;
const int maxm=25;
int _pow[maxm],m,n;
int head[maxn],ip;
int ver[maxn*2],R[maxn*2],first[maxn],dir[maxn],dp[maxn*2][maxm],tot;
bool vis[maxn];
void init()
{
memset(vis,false,sizeof(vis));
memset(head,-1,sizeof(head));
ip=0;
}
struct note
{
int v,w,next;
}edge[maxn*2];
void addedge(int u,int v,int w)
{
edge[ip].v=v,edge[ip].w=w,edge[ip].next=head[u],head[u]=ip++;
}
void dfs(int u,int dep)
{
vis[u]=true;
ver[++tot]=u,first[u]=tot,R[tot]=dep;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
int w=edge[i].w;
if(!vis[v])
{
dir[v]=dir[u]+w;
dfs(v,dep+1);
ver[++tot]=u,R[tot]=dep;
}
}
}
void ST(int len)
{
for(int i=1;i<=len;i++)
{
dp[i][0]=i;
}
for(int j=1;(1<<j)<=len;j++)
{
for(int i=1;i+(1<<j)-1<=len;i++)
{
int a=dp[i][j-1],b=dp[i+(1<<(j-1))][j-1];
if(R[a]<R[b])
dp[i][j]=a;
else
dp[i][j]=b;
}
}
}
int RMQ(int x,int y)
{
int k=(int)log((double)(y-x+1)/log(2.0));
int a=dp[x][k],b=dp[y-(1<<k)+1][k];
if(R[a]<R[b])
return a;
else
return b;
}
int LCA(int u,int v)
{
int x=first[u],y=first[v];
if(x>y)swap(x,y);
int res=RMQ(x,y);
return ver[res];
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
init();
for(int i=1;i<n;i++)
{
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
addedge(u,v,w);
addedge(v,u,w);
}
tot=0,dir[1]=0;
dfs(1,1);
ST(2*n-1);
while(m--)
{
int u,v;
scanf("%d%d",&u,&v);
int lca=LCA(u,v);
printf("%d\n",dir[u]+dir[v]-2*dir[lca]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: