您的位置:首页 > 其它

POJ 1523:SPF tarjan求割点

2017-09-13 00:55 337 查看
SPF

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9463 Accepted: 4272
Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from
communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected
network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 



Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers
will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when
that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output
Network #1
SPF node 3 leaves 2 subnets

Network #2
No SPF nodes

Network #3
SPF node 2 leaves 2 subnets
SPF node 3 leaves 2 subnets


挺好的tarjan求割点模板

锻炼输入输出能力 哈哈

求割点不多讲了,这里要求每个割点割开的联通块数

中间维护一下每个low(v)>=dfn(u)就行了

根节点注意一下就好了

话说有个小细节没仔细想,希望有大牛能评论一下告诉我怎么回事

在每次tarjan时开始的根节点要记录一下

代码中采取的是直接用root记录

我之前用了个bool数组,每次tarjan都记一下,觉得没啥问题吗,可是会WA,改掉就A了

求神犇帮蒟蒻BJ想一下下辣~~

#include<cmath>
#include<ctime>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<complex>
#include<iostream>
#include<algorithm>
#include<iomanip>
#include<vector>
#include<string>
#include<bitset>
#include<queue>
#include<map>
#include<set>
using namespace std;

typedef long long ll;

inline int read()
{
int x=0,f=1;char ch=getchar();
while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
while(ch<='9'&&ch>='0'){x=(x<<1)+(x<<3)+ch-'0';ch=getchar();}
return x*f;
}

void print(int x)
{if(x<0)putchar('-'),x=-x;if(x>=10)print(x/10);putchar(x%10+'0');}

const int N=1010,M=1000100;

int n;

int ecnt,last
;
struct EDGE{int to,nt;}e[M];
inline void add(int u,int v)
{e[++ecnt]=(EDGE){v,last[u]};last[u]=ecnt;}

int dfn
,low
,son
,cnt,root;

bool iscut
;

void initial()
{
memset(last,0,sizeof(last));ecnt=cnt=n=0;
memset(dfn,0,sizeof(dfn));memset(low,0,sizeof(low));
memset(iscut,0,sizeof(iscut));memset(son,0,sizeof(son));
}

void tarjan(int u,int fa)
{
dfn[u]=low[u]=++cnt;
son[u]=0;
for(int i=last[u],c=0;i;i=e[i].nt)if(e[i].to^fa)
{
if(!dfn[e[i].to])
{
c++;tarjan(e[i].to,u),low[u]=min(low[u],low[e[i].to]);
if((root==u&&c>1)||(root!=u&&dfn[u]<=low[e[i].to]))son[u]++;
}
else if(dfn[e[i].to]<low[u])low[u]=dfn[e[i].to];
}
}

int main()
{
register int now=0,u=1,v,i;
while(u)
{
scanf("%d",&u);if(!u)return 0;
now++;
while(u)
{
scanf("%d",&v);
add(u,v);add(v,u);n=max(n,u);n=max(n,v);
scanf("%d",&u);
}
for(u=1;u<=n;++u)if(!dfn[u])root=u,tarjan(u,0);
printf("Network #%d\n",now);
bool flag=0;
for(i=1;i<=n;++i)if(son[i])
flag=1,printf(" SPF node %d leaves %d subnets\n",i,son[i]+1);
if(!flag)puts(" No SPF nodes");
puts("");
initial();
}
return 0;
}
/*
1 2 5 4 3 1 3 2 3 4 3 5 0 1 2 2 3 3 4 4 5 5 1 0 1 2 2 3 3 4 4 6 6 3 2 5 5 1 0 0

Network #1 SPF node 3 leaves 2 subnets Network #2 No SPF nodes Network #3 SPF node 2 leaves 2 subnets SPF node 3 leaves 2 subnets
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: