您的位置:首页 > 其它

HDU 1312Red and Black(dfs)

2017-09-12 20:22 375 查看


Red and Black


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 1   Accepted Submission(s) : 1


Font: Times New Roman | Verdana | Georgia


Font Size: ← →


Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

4000
'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0



Sample Output

45
59
6
13



Source

Asia 2004, Ehime (Japan), Japan Domestic

想法:简单dfs

代码:

#include<stdio.h>
#include<string.h>
char a[25][25];
int sx,sy,ex,ey,n,m,sum;
int vir[4][2]={0,1,1,0,-1,0,0,-1};
void dfs(int x,int y)
{
sum++;
a[x][y]='#';
for(int i=0;i<4;i++)
{
int tx=x+vir[i][0];
int ty=y+vir[i][1];
if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&a[tx][ty]=='.')
{
dfs(tx,ty);
}
}
return ;
}
int main()
{
while(scanf("%d %d",&m,&n)&&n+m)
{
getchar();
for(int i=1;i<=n;i++)
{
scanf("%s",a[i]+1);
for(int j=1;j<=m;j++)
{
if(a[i][j]=='@')
{
sx=i,sy=j;
}
}
}
sum=0;
dfs(sx,sy);
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: