您的位置:首页 > 理论基础 > 计算机网络

HDU6195 | 2017 ACM-ICPC 亚洲区(沈阳赛区)网络赛-B cable cable cable

2017-09-10 19:04 495 查看


cable cable cable

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 34    Accepted Submission(s): 28


Problem Description

Connecting the display screen and signal sources which produce different color signals by cables, then the display screen can show the color of the signal source.Notice that every signal source can only send signals to one display screen each time. 

Now you have M display
screens and K different
signal sources(K≤M≤232−1).
Select K display
screens from M display
screens, how many cables are needed at least so that **any** K display
screens you select can show exactly K different
colors.

 

Input

Multiple cases (no more than 100),
for each test case:

there is one line contains two integers M and K.

 

Output

Output the minimum number of cables N.

 

Sample Input

3 2
20 15

 

Sample Output

4
90
Hint



As the picture is shown, when you select M1 and M2, M1 show the color of K1, and M2 show the color of K2.

When you select M3 and M2, M2 show the color of K1 and M3 show the color of K2.

When you select M1 and M3, M1 show the color of K1.

 

Source

2017 ACM/ICPC Asia Regional Shenyang Online

思路:至少有两个信号源和同一个屏幕相连

AC代码如下:

#include <bits/stdc++.h>
#define LL long long
using namespace std;

LL m,k;

int main(){
while(~scanf("%lld%lld",&m,&k)){
printf("%lld\n",(m - k + 1) * k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐