您的位置:首页 > 产品设计 > UI/UE

1051. Pop Sequence (25)

2017-09-10 14:41 323 查看


1051. Pop Sequence (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain
1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow,
each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO


提交代码
//20min: 42行:while(!s.empty()&&s.top()==q.front() ),不能写成while(s.top()==q.front() &&!s.empty())。注意先后顺序!!
//******总结****** 遇到多个&&时候一定要注意前后顺序!!

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <stack>
#include <queue>
using namespace std;

int main()
{
freopen("in.txt","r",stdin);

int M,N,K;
cin>>M>>N>>K;
while(K--)
{
stack<int> s;
int flag=0;
queue<int> q;
int i;
for(i=1;i<=N;i++)
{
int t;
cin>>t;
q.push(t);
}
for(i=1;i<=N;i++)
{
s.push(i);
if(s.size()>M)
{
flag=1;
//printf("111111111111111111 %d 1111\n",s.size());
break;
}
while(!s.empty()&&s.top()==q.front() )
{
s.pop();
q.pop();
}
}
if(!s.empty())
{
flag=1;
//printf("di2zhongcuo\n");
}

if(flag==1)
printf("NO\n");
else
printf("YES\n");

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: