您的位置:首页 > 其它

POJ 1328

2017-09-10 11:49 253 查看

Radar Installation

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 90690 Accepted: 20370

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

Source

Beijing 2002

个人理解:

转换为区间,降维,进行贪心,当然越建左边对后面影响越好。排序是按照右端点为第一优先级,左端点为第二优先级。WA了无数次。。。不知道为什么copy了一份别人的代码。思路差不多,只不过没有按照左端点排序,加了一个标记,重复扫描区间。

#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
const int Max = 1005;

struct
{
int x, y;
}isl[Max];

struct data
{
float sta, end;
}rad[Max];

bool cmp(data a, data b)
{
if(a.end < b.end)
return true;
else
return false;
}

int main()
{
int n, d, t = 1;
while(cin >> n >> d && n != 0)
{
int i, j, max_y = 0;
for(i = 0; i < n; i ++)
{
cin >> isl[i].x >> isl[i].y;
if(isl[i].y > max_y)
max_y = isl[i].y;
}
getchar();
getchar();

cout << "Case " << t ++ << ": ";
if(max_y > d || d < 0)
{
cout << -1 << endl;
continue;
}
float len;
for(i = 0; i < n; i ++)
{
len = sqrt(1.0 * d * d - isl[i].y * isl[i].y);
rad[i].sta = isl[i].x - len;
rad[i].end = isl[i].x + len;
}
sort(rad, rad + n, cmp);

int ans = 0;
bool vis[Max];
memset(vis, false, sizeof(vis));
for(i = 0; i < n; i ++)
{
if(!vis[i])
{
vis[i] = true;
for(j = 0; j < n; j ++)
if(!vis[j] && rad[j].sta <= rad[i].end)
vis[j] = true;
ans ++;
}
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: