您的位置:首页 > 其它

矩阵快速幂,求斐波那契数列

2017-09-10 10:38 351 查看
用矩阵的快速幂求斐波那契数列,时间复杂度为O(lgn*n^3),其中计算一次矩阵相乘复杂度为O(n^3),大大缩小了暴力相乘(1次1次乘)的时间复杂度

参考文章:

                 http://blog.csdn.net/u013795055/article/details/38599321

                 http://blog.csdn.net/g_congratulation/article/details/52734306 

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1


Sample Output
0
34
626
6875


Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

#include<stdio.h>

#include<string.h>

const int MOD=10000;  

struct Mat  

{  

    int a[2][2];  

}; 

typedef struct Mat mat;

 

mat mat_mul(mat x,mat y)//实现两个矩阵相乘,返回的还是一个矩阵。  

{  
int i,j,k;

    mat res;//用来表示得到的新的矩阵;  

    memset(res.a,0,sizeof(res.a));  

    for(i=0;i<2;i++)  

        for(j=0;j<2;j++)  

        for(k=0;k<2;k++)  

    {  

        res.a[i][j]+=x.a[i][k]*y.a[k][j];  

        res.a[i][j]%=MOD; //这一步看题目具体需要了,这里题目要求取末四位所以除万取余  

    }  

    return res;  

}

int my_pow(int n)

{  

    mat c,res;  

    int i;

    memset(res.a,0,sizeof(res.a));  

    c.a[0][0]=1;//给矩阵赋初值  

    c.a[0][1]=1;  

    c.a[1][0]=1;  

    c.a[1][1]=0;  

    for(i=0;i<2;i++) 
res.a[i][i]=1;//单位矩阵;  

    while(n)  

    {  

        if(n&1) res=mat_mul(res,c);//这里看就要用到上面的矩阵相乘了;  

        c=mat_mul(c,c);  

        //printf("%d\n",n);

        n=n>>1;     //一次循环后除二,由此计算时间复杂度为O(lgn)

    }  

    return res.a[0][1];  

}//时间复杂度lg(n)    

int main()

{
int n;
while(scanf("%d",&n) == 1)
{
if(n == -1)
break;
printf("%d\n",my_pow(n));
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: