您的位置:首页 > 其它

【HDU】 1969 Pie

2017-09-10 10:37 302 查看


Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8851    Accepted Submission(s): 3225

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one
pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

 

 

Input

One line with a positive integer: the number of test cases. Then for each test case:

---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.

---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

 

 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

 

 

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

 

 

Sample Output

25.1327 3.1416 50.2655

 

 

Source

NWERC2006

 

 

 

 

题意:有 n 块蛋糕,分给 k+1 个人(加上本人),不能拼接,每个人得到的体积一样(圆柱体高为1,表面积一样即可)。问分的蛋糕最大为多少。

题解:从0 和表面积最大的那一块之间用二分,注意用 r - l 控制精度就行(1e-5才能AC)。

代码:

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
int n,k;
double pie[10000+11];
bool check(double t)
{
int ant = 0;
for (int i = 1 ; i <= n ; i++)
{
ant += (int)(pie[i] / t);
if (ant >= k)
return true;
}
return false;
}
int main()
{
int u;
double l,r,mid;
scanf ("%d",&u);
while (u--)
{
scanf ("%d %d",&n,&k);
k++; //加上本人
l = r = 0;
for (int i = 1 ; i <= n ; i++)
{
scanf ("%lf",&pie[i]);
pie[i] = pie[i] * pie[i] * PI;
r = max (r , pie[i]); //max函数是c++<algorithm>里面的,这个地方错了好久,刚开始头文件没写,c里面没有max函数,在c里要自己写
}
while (r - l > 0.00001) //控制精度(大十倍就会WA) 这个地方l r不是整数,不能这样写while(l<=r)
{
mid = (l + r) / 2.0;
if (check(mid))
l = mid;
else
r = mid;
}
printf ("%.4lf\n",l);
}
return 0;
}
代码来源:http://blog.csdn.net/wyg1997/article/details/51822930  不是原创,不过看了他的思路明白了,自己也写出来了,就是那个max函数,我用的c...,在改错的过程中把自己代码弄得太乱了,就直接引用了别人的代码...
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: