您的位置:首页 > 其它

POJ1163 The Triangle

2017-09-09 21:17 246 查看

题目:

Description

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

Source

IOI 1994

解答:

//POJ1163
//A
//B C
//D E F
//G H I J
//K L M N O
//P Q R S T U

/*
#include<iostream>
#include<algorithm>
#define MAX 101
using namespace std;
int D[MAX][MAX];
int n;
int MaxSum(int i,int j){
if(i==n)return D[i][j];
int x=MaxSum(i+1,j),y=MaxSum(i+1,j+1);
return max(x,y)+D[i][j];
}
int main(){
int i,j;
cin>>n;
for(i=1;i<=n;i++)
for(j=1;j<=i;j++){
cin>>D[i][j];
}

cout<<MaxSum(1,1)<<endl;
return 0;
}//超时
*/
/*
#include<iostream>
#include<algorithm>
#define MAX 101
using namespace std;
int D[MAX][MAX];
int maxSum[MAX][MAX];/////////////////////////////////
int n;
int MaxSum(int i,int j){
if(maxSum[i][j]!=-1)return maxSum[i][j];//////////
if(i==n)return D[i][j];
int x=MaxSum(i+1,j),y=MaxSum(i+1,j+1);
return max(x,y)+D[i][j];
}
int main(){
int i,j;
cin>>n;
for(i=1;i<=n;i++)
for(j=1;j<=i;j++){
cin>>D[i][j];
maxSum[i][j]=-1;//////////////////////////
}

cout<<MaxSum(1,1)<<endl;
return 0;
}////////数字三角形的记忆递归型动态规划程序。
*/
/*
//递归变递推:
#include<iostream>
#include<algorithm>
#define MAX 101
using namespace std;
int D[MAX][MAX];
int maxSum[MAX][MAX];
int n;
int main(){
int i,j;
cin>>n;
for(int i=1;i<=n;i++)for(int j=1;j<=i;j++)cin>>D[i][j];
for(int i=1;i<=n;i++)maxSum
[i]=D
[i];
for(int i=n-1;i>=1;i--)for(int j=1;j<=i;j++)maxSum[i][j]=max(maxSum[i+1][j],maxSum[i+1][j+1])+D[i][j];
cout<<maxSum[1][1]<<endl;
return 0;
}*/
//继续空间优化 //将maxSum二维数组换成一维
//利用滚动数组,把原本上一行的运算数值保存在这一行。
#include<iostream>
#include<algorithm>
#define MAX 101
using namespace std;
int D[MAX][MAX];
int maxSum[MAX];
int n;
int main(){
int i,j;
cin>>n;
for(int i=1;i<=n;i++)for(int j=1;j<=i;j++)cin>>D[i][j];
for(int i=1;i<=n;i++)maxSum[i]=D
[i];
for(int i=n-1;i>=1;i--)for(int j=1;j<=i;j++)maxSum[j]=max(maxSum[j],maxSum[j+1])+D[i][j];
cout<<maxSum[1]<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: