您的位置:首页 > 其它

[DP] POJ - 1163 The Triangle

2017-09-09 19:33 281 查看
The Triangle

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 51206 Accepted: 31010

Description

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

题意:输入一个n层的三角形,求从第1层到第n层的所有路线中,权值之和最大的路线。

规定:第i层的某个数只能连线走到第i+1层中与它位置相邻的两个数中的一个。

//已AC代码
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>
using namespace std;

int main()
{
int t;
int ans=0;
int a[188][188];
int dp[188][188];
memset(a,0,sizeof(a));
memset(dp,0,sizeof(dp));
cin>>t;
for(int i=1;i<=t;i++)
{
for(int j=1;j<=i;j++)
{
cin>>a[i][j];
}
}
for(int i=1;i<=t;i++)
{
for(int j=1;j<=i;j++)
{
if(i==1&&j==1)
{
dp[i][j]=a[1][1];
}
else if(j==1)
{
dp[i][j]=dp[i-1][j]+a[i][j];
}
else if(j==i)
{
dp[i][j]=dp[i-1][j-1]+a[i][j];
}
else
dp[i][j]=a[i][j]+max(dp[i-1][j],dp[i-1][j-1]);

}
}

for(int i=1;i<=t;i++)
{
if(dp[t][i]>=ans)
ans=dp[t][i];
}
cout<<ans<<endl;

}


再贴一个大神的代码,只用了20行!!! 膜拜

#include<stdio.h>
int main(){
int n, i, j;
scanf("%d", &n);
int **a = new int*
;
for(i = 0; i < n; ++i){
a[i] = new int[i + 1];
for(j = 0; j <= i; ++j){
scanf("%d", &a[i][j]);
}
}
for(i = n - 2; i >=0; --i){
for(j = 0; j <= i; ++j){
a[i][j] += a[i + 1][j] > a[i + 1][j + 1] ? a[i + 1][j] : a[i + 1][j + 1];
}
}
printf("%d", a[0][0]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: