您的位置:首页 > 理论基础 > 计算机网络

2017 ACM-ICPC 亚洲区(乌鲁木齐赛区)网络赛 A: Banana

2017-09-09 18:32 561 查看
A: Banana

time limit

200ms

memory limit

131072KB

Bananas are the favoured food of monkeys.

In the forest, there is a Banana Company that provides bananas from different places.

The company has two lists.

The first list records the types of bananas preferred by different monkeys, and the second one records the types of bananas from different places.

Now, the supplier wants to know, whether a monkey can accept at least one type of bananas from a place.

Remenber that, there could be more than one types of bananas from a place, and there also could be more than one types of bananas of a monkey's preference.

Input Format

The first line contains an integerT , indicating that there areT test
cases.

For each test case, the first line contains two integersN andM,
representing the length of the first and the second lists respectively.

In the each line of followingN lines, two positive integersi, j indicate
that thei-th monkey favours thej-th type of banana.

In the each line of followingM lines, two positive integersj, k indicate
that thej-th type of banana could be find in thek-th place.

All integers of the input are less than50.

Output Format

For each test case, output all the pairsx, y that
thex-the monkey can accept at least one type of bananas from they-th place.

These pairs should be outputted as ascending order. That is say that a pair ofx, y which
owns a smallerx should be output first.

If two pairs own the samex, output the one who has a smallery first.

And there should be an empty line after each test case.

Sample Input

 1

6 4

1 1

1 2
2 1
2 3
3 3
4 1
1 1
1 3
3 3
Sample Output

1 1

1 2
1 3
2 1
2 3
3 3
4 1
4 3
题意:输入T组数据,每组数据第一行为两个整数n m,第一个整数n为下面有n行数据,每行数据有2个整数i、j,代表编号为i的猴子喜欢吃类型为j的香蕉,n行结束后,又有m行,每行有j k两个整数,代表着类型为j的香蕉在位置k的地方放着,要求解编号为i的猴子去哪个地方(k)可以找到他爱吃的类型的香蕉。
注:地方k可以有好几种类型的香蕉(j1,j2......),如果猴子i喜欢的香蕉种类j1,j2都在一个k的话,只能输出一个。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#define Max 51
using namespace std;
int n,m,vary[Max][2],place[Max][2];
int ans;
struct M
{
int monkey_name;
int places;
//int flag;
}A[100];
bool cmp(struct M a,struct M b)
{
if(a.monkey_name==b.monkey_name)
return a.places<b.places;
else
return a.monkey_name<b.monkey_name;
}
void find_place(int monkey,int banana_name)
{
for(int i=0;i<m;++i)
{
if(banana_name==place[i][0])
{
A[ans].monkey_name=monkey;
A[ans++].places=place[i][1];
//A[ans++].flag=0;
}
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
ans=0;
cin>>n>>m;
for(int i=0;i<n;++i)
cin>>vary[i][0]>>vary[i][1];
for(int i=0;i<m;++i)
cin>>place[i][0]>>place[i][1];
for(int i=0;i<n;++i)
find_place(vary[i][0],vary[i][1]);
sort(A,A+ans,cmp);
cout<<A[0].monkey_name<<' '<<A[0].places<<endl;
for(int i=1;i<ans;++i)
{
if(!(A[i].monkey_name==A[i-1].monkey_name&&A[i].places==A[i-1].places))
cout<<A[i].monkey_name<<' '<<A[i].places<<endl;
}
cout<<endl;
}
}
还有一段没有理解的:
#include<stdio.h>
#include<string.h>
#define MAX 55
int monkey[MAX][MAX],place[MAX][MAX],m_p[MAX][MAX];
int main()
{
int T,N,M;
int i,j;
int t1,t2,t3;
scanf("%d",&T);
while(T--)
{
memset(monkey,0,sizeof(monkey));
memset(place,0,sizeof(place));
memset(m_p,0,sizeof(m_p));
scanf("%d %d",&N,&M);
for(i=0;i<N;i++)
{
scanf("%d %d",&t1,&t2);
monkey[t1][t2] = 1;
}
for(i=0;i<M;i++)
{
scanf("%d %d",&t2,&t3);
place[t2][t3] = 1;
}
for(t1=1;t1<=N;t1++)
{
for(t2=1;t2<=N;t2++)
{
if(monkey[t1][t2]==1)
{
for(t3=1;t3<=N;t3++)
{
if(place[t2][t3]==1)
m_p[t1][t3] = 1;
}
}
}
}
for(t1=1;t1<=N;t1++)
for(t3=1;t3<=N;t3++)
if(m_p[t1][t3]==1)
printf("%d %d\n",t1,t3);
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐