您的位置:首页 > 其它

POJ 1330 Nearest Common Ancestors(LCA 在线算法)

2017-09-09 10:48 387 查看
Description
A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:



In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor
of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node
x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common
ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest
common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree,
2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges.
The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.
Output
Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.
Sample Input
2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output
4
3


题目大意:找最近公共祖先。
这里使用在线算法,用到了ST表。先对树进行一次 DFS 记录每个点的深度和 DFS 序(DFS 序要记录深搜的路径,有的点可能出现多次)以及每个点第一次在 DFS 序中出现的位置。任意两点的最近公共祖先即为这两个点在 DFS 序中第一次出现的位置之间深度最小的点,这里可以用 ST 表快速查询区间最值。
代码:
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 1e4 + 5;
int n;
vector<int> v[maxn];
int in[maxn];
int pos[maxn],dfs[maxn << 1],depth[maxn];
int st[maxn << 1][20];
int dfs_size;
void Init()
{
dfs_size = 0;
for(int i = 1;i <= n; ++i)
{
in[i] = 0;
v[i].clear();
}
}
int DFS(int x,int d)
{
depth[x] = d;
dfs[dfs_size] = x;
pos[x] = dfs_size++;
int len = v[x].size();
for(int i = 0;i < len; ++i)
{
int u = v[x][i];
DFS(u,d + 1);
dfs[dfs_size++] = x;
}
}
void ST()
{
int len = dfs_size;
for(int i = 0;i < len; ++i) st[i][0] = dfs[i];
for(int j = 1;(1 << j) <= len; ++j)
{
for(int i = 0;i + (1 << j) - 1 < len; ++i)
{
int l = st[i][j - 1],r = st[i + (1 << (j - 1))][j - 1];
st[i][j] = depth[l] < depth[r] ? l : r;
}
}
}
int LCA(int x,int y)
{
x = pos[x],y = pos[y];
if(x > y) swap(x,y);
int k = 0;
while((1 << (k + 1)) <= y - x + 1) ++k;
int a = st[x][k],b = st[y - (1 << k) + 1][k];
return depth[a] < depth[b] ? a : b;
}
int main()
{
int t,root;
scanf("%d",&t);
while(t--)
{
Init();
scanf("%d",&n);
int x,y;
for(int i = 1;i < n; ++i)
{
scanf("%d %d",&x,&y);
v[x].push_back(y);
in[y]++;
}
for(int i = 1;i <= n; ++i)
{
if(!in[i])
{
root = i;
break;
}
}
DFS(root,1);
ST();
int a,b;
scanf("%d %d",&a,&b);
printf("%d\n",LCA(a,b));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: