您的位置:首页 > 其它

POJ1753 Flip Game(搜索,枚举,位运算压缩)

2017-09-08 19:52 423 查看
POJ1753

Description:

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces wh
4000
ite side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb

bbwb

bwwb

bwww

Sample Output

4

分析:

第一种方法,枚举法+dfs+回溯:

#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int chess[4][4];
int c=33;
void build(){
char c;
for(int i=0;i<4;i++)
for(int j=0;j<4;j++){
cin>>c;
if(c=='w')
chess[i][j]=0;
else
chess[i][j]=1;
}
}
void turn(int x,int y)//翻转
{
if(x>=0&&x<=3&&y>=0&&y<=3)
chess[x][y]=!chess[x][y];
}
void flip(int s)//一个棋子变化,周围四个都要变化
{
int i=s/4;//行
int j=s%4;//列
turn(i,j);
turn(i+1,j);
turn(i,j+1);
turn(i-1,j);
turn(i,j-1);
}
int complete()//判断棋盘是否变成同一的颜色
{
int i,j,s1=0;
for(i=0;i<4;i++)
for(j=0;j<4;j++)
s1+=chess[i][j];
if(s1%16)
return 0;
else
return 1;
}

void dfs(int s,int b){  //s代表当前的方格,b代表翻转的方格数
if(complete()){ //同一颜色,找到最终状态
if(c>b) c=b;
return ;
}
if(s>=16) //如果遍历完
return ;
dfs(s+1,b);
flip(s);
dfs(s+1,b+1);
flip(s);
}

int main(){
build();
dfs(0,0);
if(c==33) //反转最多4*4*2次
cout<<"Impossible"<<endl;
else
cout<<c<<endl;
return 0;
}


第二种方法: bfs+位压缩:

有关压缩的知识以及详解:http://www.cnblogs.com/ziyi–caolu/p/3463808.html

AC:

#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int t[20]={
51200,58368,29184,12544,
35968,20032,10016,4880,
2248,1252,626,305,
140,78,39,19,
};
int M=1<<16;
bool vis[(1<<16)];
struct node{
int k,step;
};

void bfs(int ans){
queue<node > q;
node p;
p.k=ans;
p.step=0;
q.push(p);
while(!q.empty()){
p=q.front();
q.pop();
if(p.k==0 ||p.k==(M-1)){ //全是黑或者全是白
cout<<p.step<<endl;
return ;
}
for(int i=0;i<16;i++){
node p1;
p1.step=p.step+1;
p1.k=p.k^t[i]; //对其进行异或变换,一共有十六种种变化
if(!vis[p1.k]){
vis[p1.k]=true;
q.push(p1);
}
}
}
cout<<"Impossible"<<endl;
}

int main(){
int ans=0,cnt=15;
for(int i=0;i<4;i++){
char ch[10];
scanf("%s",ch);
//将原图转换为二进制表示
for(int j=0;j<4;j++){
if(ch[j]=='b'){
//1<<cnt指的是1向左移动cnt位,等效于1的cnt次方
//ans|= 等价于二进制中的异或运算,有一个是1就是1
ans |=(1<<cnt);
}
cnt--;
}
}
memset(vis,false,sizeof(vis));
vis[ans]=true;
bfs(ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: