您的位置:首页 > 理论基础

1175:ACM水题

2017-09-08 16:16 246 查看
1175:ACM水题

Description

ACM中把一种题称作“水题”,顾名思义就是题目很水,很简单。为了促进提高大伙的编程兴趣, 
zjahstu决定贯彻“没有最水,只有更水”的原则。 

现在给定两个数a和b, 计算[a,b]之间整数的和。(当a=b=0时候表示输入结束,不必处理)

Input

1 100 
1 10 
99 100 
0 0

Output

5050 

55 

199

Sample Input

1 100

1 10

99 100

0 0

Sample Output

5050

55

199

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
int a,b,i;
while(2==scanf("%d%d",&a,&b))
{
if(a==0&&b==0)
return 0;
int count=0;
for(i=a;i<=b;i++)
{
count=count+i;
}
cout<<count<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息