您的位置:首页 > 大数据 > 人工智能

PAT 1090. Highest Price in Supply Chain (25) 必须用double,未解之谜

2017-09-08 12:49 483 查看


1090. Highest Price in Supply Chain (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root
supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price
given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for
the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the
price will not exceed 1010.
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

下面快速幂那里必须用double,原因未知,应该不会爆啊。

#include <iostream>
#include<stdio.h>
#include<string>
#include<algorithm>
#include<string.h>
#include<vector>
using namespace std;

vector<int> node[100002];
int father[100005];
int mark[100001]={0};
int maxx=-1;
int cnt=0;
void dfs(int x,int cengshu)
{
mark[x]=1;
if(cengshu>maxx)
{
maxx=cengshu;
cnt=1;
}
else if(cengshu==maxx)
{
cnt++;
}
for(int i=0;i<node[x].size();i++)
{
int tmp=node[x][i];
dfs(tmp,cengshu+1);
}

}

int main()
{
int n;
double p,r;
cin>>n>>p>>r;
for(int i=0;i<n;i++)
{
cin>>father[i];
if(father[i]==-1) father[i]=100001;
node[father[i]].push_back(i);
}
dfs(100001,0);
double rr=(100+r)/100;
int num=maxx-1;
double a=1; //此处必须是double,原因未知
while(num>0)
{
if(num%2==1) a*=rr;
rr*=rr;
num/=2;
}
a*=p;
printf("%.2f %d",a,cnt);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: