您的位置:首页 > 其它

poj 3617 贪心

2017-09-08 08:25 232 查看
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual”Farmer of the Year” competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

Line 1: A single integer: N

Lines 2..N+1: Line i+1 contains a single initial (‘A’..’Z’) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’..’Z’) in the new line.

Sample Input

6

A

C

D

B

C

B

Sample Output

ABCBCD

题解:

不断取S的开头和末尾中较小的一个字符放到T的末尾。

如果相同,则继续比较下一位。

PE了两次,注意每行80个。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int MAX_N = 2000+100;
int N;
char S[MAX_N+1];
vector<char> vec;
void solve()
{
int a=0,b=N-1;
while(a<=b)
{
bool left=false;
for(int i=0;a+i<=b;i++)
{
if(S[a+i]<S[b-i])
{
left=true;
break;
}
else if(S[a+i]>S[b-i])
{
left=false;
break;
}
}
if(left) vec.push_back(S[a++]);
else vec.push_back(S[b--]);
}

}

int main()
{
scanf("%d",&N);
for(int i=0;i<N;i++)
cin>>S[i];
solve();
int siz = vec.size();
int ans=0;
for(int i=0;i<siz;i++)
{
putchar(vec[i]);
ans++;
if(ans%80==0)
{
putchar('\n');
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: