您的位置:首页 > 其它

HDU 1385 Minimum Transport Cost【最短路之路径记录】

2017-09-07 20:22 381 查看

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11410 Accepted Submission(s): 3191

Problem Description

 These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:

The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N

a21 a22 … a2N

……………

aN1 aN2 … aNN

b1 b2 … bN

c d

e f



g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output

From c to d :

Path: c–>c1–>……–>ck–>d

Total cost : ……

……

From e to f :

Path: e–>e1–>……….–>ek–>f

Total cost : ……

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5

0 3 22 -1 4

3 0 5 -1 -1

22 5 0 9 20

-1 -1 9 0 4

4 -1 20 4 0

5 17 8 3 1

1 3

3 5

2 4

-1 -1

0

Sample Output

From 1 to 3 :

Path: 1–>5–>4–>3

Total cost : 21

From 3 to 5 :

Path: 3–>4–>5

Total cost : 16

From 2 to 4 :

Path: 2–>1–>5–>4

Total cost : 17

题意概括:

   有n个城市,城市之间由一些道路连接,也有一些城市不能相互连接。现在有一些货物需要从一个城市运送到另一个城市,运输的费用由两部分组成,分别是通过每条道路所需的费用和通过一个城市时需缴纳的税收,起点和终点城市的税收可以不计。输出花费最小的路径和最小的花费。若有多条最短路径输出字典序最小的那条。

解题分析:

  这道题因为要记录路径且对于同一组数据有多组询问,用Floyd比较方便。用一个数组g[i][j]记录从i到j的最短路中的第一个需到达的点。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N = 1000, inf = 99999999;

int n;
int c
, e

, g

;

void Floyd(void)
{
int i, j, k, t;
for(i = 1; i <= n; i++)
for(j = 1; j <= n; j++)
g[i][j] = j;
for(k = 1; k <= n; k++){
for(i = 1; i <= n; i++){
for(j = 1; j <= n; j++){
t = e[i][k] + e[k][j] + c[k];
if(e[i][j] > t){
e[i][j] = t;
g[i][j] = g[i][k];
}
else if(e[i][j] == t)
g[i][j] = min(g[i][j], g[i][k]);
}
}
}
}

int main()
{
int i, j, u, v;
while(scanf("%d", &n), n){
for(i = 1; i <= n; i++){
for(j = 1; j <= n; j++){
scanf("%d", &e[i][j]);
if(e[i][j] == -1)
e[i][j] = inf;
}
}
for(i = 1; i <= n; i++)
scanf("%d", &c[i]);
Floyd();
while(scanf("%d%d", &u, &v), u != -1 || v != -1){
printf("From %d to %d :\nPath: %d", u, v, u);
int tmp = u;
while(tmp != v){
printf("-->%d", g[tmp][v]);
tmp = g[tmp][v];
}
printf("\n");
printf("Total cost : %d\n\n", e[u][v]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息