您的位置:首页 > 其它

poj1703 Find them, Catch them——带权并查集

2017-09-07 17:38 363 查看
Language:DefaultFind them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 47233Accepted: 14548
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

InputThe first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M li
4000
nes each containing one message as described above. OutputFor each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”Sample Input1

5 5

A 1 2

D 1 2

A 1 2

D 2 4

A 1 4

Sample OutputNot sure yet.

In different gangs.

In the same gang.

SourcePOJ Monthly–2004.07.18

题意:给定两个帮派 A是查询xy是否在同一个帮派 D是给定xy不在同一个帮派

① 给每个人x设定一个与他不在同一个帮派的人 标号是x+n 这样如果x与y不在同一帮派 那么就有x与y+n x+n与y在同一帮派 查询时需分别查询

② 带权并查集 设一个r数组 代表这个节点与其父节点的关系 0为在同一个帮派 1为不在同一个帮派

更新时的代码要好好注意



#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 101000
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;

int pre[max_*2];
int n,m;
int find(int x)
{
return pre[x]==x?x:pre[x]=find(pre[x]);
}
void join(int x,int y)
{
x=find(x);
y=find(y);
if(x!=y)
pre[x]=y;
}
int main(int argc, char const *argv[])
{
int t;
scanf("%d",&t);
while(t--)
{
memset(pre,0,sizeof(pre));
scanf("%d%d",&n,&m);
for(int i=1;i<=2*n;i++)
pre[i]=i;
while(m--)
{
char c;
int x,y;
scanf(" %c%d%d",&c,&x,&y);
if(c=='A')
{
if((find(x)==find(y+n)&&(find(x+n)==find(y))))
printf("In different gangs.\n");
else if(find(x)==find(y))
printf("In the same gang.\n");
else
printf("Not sure yet.\n");
}
else
{
join(x,y+n);
join(x+n,y);
}
}
}
return 0;
}




#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 101000
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;

int pre[max_],r[max_];
int n,m;
int find(int x)
{
if(x==pre[x])
return x;
int tmp=pre[x];
pre[x]=find(pre[x]);
r[x]=(r[tmp]+r[x])%2;
return pre[x];
}
void join(int x,int y)
{
int tx=find(x);
int ty=find(y);
if(tx!=ty)
{
pre[tx]=ty;
r[tx]=(r[x]+r[y]+1)%2;
}
}
int main(int argc, char const *argv[])
{
int t;
scanf("%d",&t);
while(t--)
{
memset(r,0,sizeof(r));
memset(pre,0,sizeof(pre));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
pre[i]=i,r[i]=0;
while(m--)
{
char c;
int x,y;
scanf(" %c%d%d",&c,&x,&y);
if(c=='A')
{
if(find(x)!=find(y))
printf("Not sure yet.\n");
else if(r[x]==r[y])
printf("In the same gang.\n");
else
printf("In different gangs.\n");
}
else
{
join(x,y);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: