您的位置:首页 > 运维架构

bzoj 1688: [Usaco2005 Open]Disease Manangement 疾病管理(状压)

2017-09-07 14:36 393 查看

1688: [Usaco2005 Open]Disease Manangement 疾病管理

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 706  Solved: 456

[Submit][Status][Discuss]

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible.
If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the
milk.

Input

* Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first
integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

Output

* Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2

0---------第一头牛患0种病

1 1------第二头牛患一种病,为第一种病

1 2

1 3

2 2 1

2 2 1

Sample Output

5

题目中文部分少了一句话:答案要尽可能大

因为疾病不超过15种,所以可以暴力每一种疾病组合方式,然后判断只患这些疾病的有多少头牛

复杂度O(2^d+C(d, k)*nd)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct
{
int m;
int a[17];
}Cow;
Cow s[1005];
int main(void)
{
int n, i, j, d, k, p, sum, ans, b[17];
scanf("%d%d%d", &n, &d, &k);
for(i=1;i<=n;i++)
{
scanf("%d", &s[i].m);
for(j=1;j<=s[i].m;j++)
scanf("%d", &s[i].a[j]);
}
ans = 0;
for(i=1;i<(1<<d);i++)
{
sum = 0;
memset(b, 0, sizeof(b));
for(j=0;j<=d-1;j++)
{
if(i&(1<<j))
b[j+1] = 1, sum++;
}
if(sum!=k)
continue;
sum = 0;
for(j=1;j<=n;j++)
{
for(p=1;p<=s[j].m;p++)
{
if(b[s[j].a[p]]==0)
break;
}
if(p==s[j].m+1)
sum++;
}
ans = max(ans, sum);
}
printf("%d\n", ans);
return 0;
}
/*
6 3 2
0
1 1
1 2
1 3
2 2 1
2 2 1
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: