您的位置:首页 > 产品设计 > UI/UE

hdu 5950 Recursive sequence (矩阵快速幂)

2017-09-06 21:20 253 查看


Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1710    Accepted Submission(s): 780


Problem Description

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their
identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4.
Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 

 

Input

The first line of input contains an integer t, the number of test cases. t test cases follow.

Each case contains only one line with three numbers N, a and b where N,a,b < 231 as
described above.

 

Output

For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.

 

Sample Input

2
3 1 2
4 1 10

 

Sample Output

85
369
HintIn the first case, the third number is 85 = 2*1十2十3^4.
In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

 

Source

2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

 

Recommend

jiangzijing2015

科普一个知识 

n ^4 = (n-1+1)^4=二项式展开 = C(0,4)(n-1)^4 +C(1,4)(n-1)^3+C(2,4)(n-1)^2+C(3,4)(n-1)+C(4,4);

杨辉三角和组合数的关系,,

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define mem(a) memset(a,0,sizeof(a))
#define ll long long
#define Mod 2147493647
using namespace std;
int Tri[5][5];
void init()
{
for(int i=0;i<5;i++)
{
for(int j=0;j<=i;j++)
{
if(i==j||j==0)
Tri[i][j]=1;
else Tri[i][j]=Tri[i-1][j]+Tri[i-1][j-1];
}
}
}
struct data
{
ll m[7][7];
data operator*(const data &a)const
{
data tmp;
mem(tmp.m);
for(int i=0;i<7;i++)
{
for(int j=0;j<7;j++)
{
for(int k=0;k<7;k++)
{
tmp.m[i][j]+=(m[i][k]*a.m[k][j]);
tmp.m[i][j]%=Mod;
}
}
}
return tmp;
}
}a,b,c;

int solve()
{
init();
ll k, First, Second;
cin>>k>>First>>Second;
if(k==1)
return First%Mod;
if(k==2)
return Second%Mod;
data tmp,res;
k-=2;
mem(res.m);
mem(tmp.m);
res.m[0][0]=Second,res.m[1][0]=First,res.m[2][0]=16,res.m[3][0]=8,res.m[4][0]=4,res.m[5][0]=2,res.m[6][0]=1;
tmp.m[0][0]=1,tmp.m[0][1]=2,tmp.m[0][2]=Tri[4][0],tmp.m[0][3]=Tri[4][1],tmp.m[0][4]=Tri[4][2],tmp.m[0][5]=Tri[4][3],tmp.m[0][6]=Tri[4][4];
tmp.m[1][0]=1,tmp.m[1][1]=0,tmp.m[1][2]=0,tmp.m[1][3]=0,tmp.m[1][4]=0,tmp.m[1][5]=0,tmp.m[1][6]=0;
tmp.m[2][0]=0,tmp.m[2][1]=0,tmp.m[2][2]=Tri[4][0],tmp.m[2][3]=Tri[4][1],tmp.m[2][4]=Tri[4][2],tmp.m[2][5]=Tri[4][3],tmp.m[2][6]=Tri[4][4];
tmp.m[3][0]=0,tmp.m[3][1]=0,tmp.m[3][2]=0,tmp.m[3][3]=Tri[3][0],tmp.m[3][4]=Tri[3][1],tmp.m[3][5]=Tri[3][2],tmp.m[3][6]=Tri[3][3];
tmp.m[4][0]=0,tmp.m[4][1]=0,tmp.m[4][2]=0,tmp.m[4][3]=0,tmp.m[4][4]=Tri[2][0],tmp.m[4][5]=Tri[2][1],tmp.m[4][6]=Tri[2][2];
tmp.m[5][0]=0,tmp.m[5][1]=0,tmp.m[5][2]=0,tmp.m[5][3]=0,tmp.m[5][4]=0,tmp.m[5][5]=Tri[1][0],tmp.m[5][6]=Tri[1][1];
tmp.m[6][0]=0,tmp.m[6][1]=0,tmp.m[6][2]=0,tmp.m[6][3]=0,tmp.m[6][4]=0,tmp.m[6][5]=0,tmp.m[6][6]=1;
while(k)
{
if(k%2)
res=tmp*res;
tmp=tmp*tmp;
k/=2;
}
return res.m[0][0]%Mod;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
ll res=solve();
printf("%lld\n",res);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: