您的位置:首页 > 其它

poj_2142_欧几里得扩展解延伸_理解过程紧张刺激

2017-09-06 20:16 225 查看
The Balance

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights.

You are asked to help her by calculating how many weights are required.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider “no solution” cases.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions.

You can measure dmg using x many amg weights and y many bmg weights.

The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition.

The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200

500 200 300

500 200 500

275 110 330

275 110 385

648 375 4002

3 1 10000

0 0 0

Sample Output

1 3

1 1

1 0

0 3

1 1

49 74

3333 1

题意:
给你两种砝码质量为a,b 去称质量为d的药品;
就是解ax+by=d
要求
1.x+y最小2.用的砝码质量最小;
解:
解这个 x,y要么一个正一个负,要么都是正,枚举每个解


//time º¯ÊýµÄʹÓÃ
#include<cstdio>
#include<iostream>
#include<ctime>
#include<algorithm>
#include<cmath>
clock_t st,ed;
double ans;
using namespace std;
int x,y;
int ex_gcd(int a,int b)
{
if(!b)
{
x=1,y=0;
return a;
}
int r=ex_gcd(b,a%b);
int t=x;
x=y;
y=t-a/b*y;
return r;
}
int main()
{
int a,b,d,i,j;
while(cin>>a>>b>>d &&(a+b+d))
{
int r=ex_gcd(a,b),vx,vy;
a/=r,b/=r;
vx=x*d/r;
vx=(vx%b+b)%b; //保证vx一定为正
vy=(d/r-a*vx)/b;
vy=abs(vy);

y=y*d/r;
y=(y%a+a)%a;
x=(d/r-b*y)/a;
x=abs(x);
if(x+y > vx+vy)
{
x=vx;
y=vy;
}

printf("%d %d\n",x,y);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj