您的位置:首页 > 产品设计 > UI/UE

01-复杂度2 Maximum Subsequence Sum

2017-09-06 13:35 459 查看
01-复杂度2 Maximum Subsequence Sum   (25分)

Given a sequence of KK integers
{ N_1N​1​​, N_2N​2​​,
..., N_KN​K​​ }.
A continuous subsequence is defined to be { N_iN​i​​, N_{i+1}N​i+1​​,
..., N_jN​j​​ }
where 1 \le i \le j \le K1≤i≤j≤K.
The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.


Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KK (\le
10000≤10000).
The second line contains KK numbers,
separated by a space.


Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence
is not unique, output the one with the smallest indices ii and jj (as
shown by the sample case). If all the KK numbers
are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


程序如下:

#include<stdio.h>
int main()
{
int n,k=0,allMinus=0,startNum,endNum,StartAndEnd=0,minSE=1000,nowSum,maxSum=0;
scanf("%d",&n);
int list[n+1];
for(int i=0;i<n;i++){
scanf("%d",&list[i]);
if(list[i]<0){
allMinus++;
}
}
startNum=list[0];
for(int i=0;i<n;i++){
nowSum+=list[i];
if(nowSum<=0){
nowSum=0;
}
if(nowSum>maxSum){
maxSum=nowSum;
endNum=list[i];
            int j=i,maySt,findStart=0;
            for(j=i;j>=0;j--){
            	findStart+=list[j];
            	if(findStart==maxSum){
            		maySt=j;
            	}
            }
            startNum=list[maySt];
}
   	}
   	if(maxSum>0){
printf("%d %d %d",maxSum,startNum,endNum);
}
else{
if(allMinus==n){
printf("%d %d %d",0,list[0],list[n-1]);
}
else{
printf("%d %d %d",0,0,0);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: