您的位置:首页 > 其它

【2017广西邀请赛】hdu 6186 CS Course

2017-09-06 11:52 369 查看
Problem Description

Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,⋯,an,
and some queries.

A query only contains a positive integer p, which means you 

are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.

 

Input

There are no more than 15 test cases. 

Each test case begins with two positive integers n and p

in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤105

Then n non-negative integers a1,a2,⋯,an follows
in a line, 0≤ai≤109 for
each i in range[1,n].

After that there are q positive integers p1,p2,⋯,pqin
q lines, 1≤pi≤n for
each i in range[1,q].

 

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in
a line.

 

Sample Input

3 3
1 1 1
1
2
3

 

Sample Output

1 1 0
1 1 0
1 1 0

 

题意:

求n个数,q个询问,求除了第p个数的&,|,^。

思路:

异或的话直接求出所有的数的异或,然后异或询问值。

与,或的话统计所有数每个位上的值。如果剩余数在当前位上的值大于0,则或值加上这个位的值。

如果剩余数早当前位上的值等于n-1,则与值加上这个位上的值。

//
// main.cpp
// 1005
//
// Created by zc on 2017/9/6.
// Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define ll long long
using namespace std;
const int N=110000;
int n,q,b
[40],c[40],p;
ll a
;

int main(int argc, const char * argv[]) {
while(~scanf("%d%d",&n,&q))
{
ll ans3=0;
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for(int i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
ans3^=a[i];
for(int j=0;j<33;j++)
{
if(a[i]&(1LL<<j)) b[i][j]=1;
c[j]+=b[i][j];
}
}
for(int i=0;i<q;i++)
{
scanf("%d",&p);
ll ans1=0,ans2=0;
for(int j=0;j<33;j++)
{
if(c[j]-b[p][j]==n-1) ans1+=(1LL<<j);
if(c[j]-b[p][j]>0) ans2+=(1LL<<j);
}
printf("%lld %lld %lld\n",ans1,ans2,ans3^a[p]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: