您的位置:首页 > 其它

【2017广西邀请赛】hdu 6182 A Math Problem

2017-09-06 08:13 381 查看
Problem Description

You are given a positive integer n, please count how many positive integers k satisfy kk≤n.

 

Input

There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1≤n≤1018

 

Output

For each test case, output an integer indicates the number of positive integers k satisfy kk≤n in
a line.

 

Sample Input

1
4

 

Sample Output

1
2

 

暴力枚举

//
// main.cpp
// A
//
// Created by zc on 2017/9/6.
// Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;

ll n;

int main(int argc, const char * argv[]) {
while(~scanf("%lld",&n))
{
int ans=0;
for(int i=1;i<=15;i++)
{
ll sum=1;
for(int j=1;j<=i;j++)
{
sum*=(ll)i;
}
if(sum<=n) ans++;
else break;
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: