您的位置:首页 > 编程语言 > C语言/C++

POJ2240-Arbitrage-C语言&&NYOJ-188

2017-09-06 00:00 363 查看
Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24506 Accepted: 10374
Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output
Case 1: Yes
Case 2: No

Source

Ulm Local 1996

题目大意:

题意:给出一些货币和货币之间的兑换比率,问是否可以使某种货币经过一些列兑换之后,货币值增加。举例说就是1美元经过一些兑换之后,超过1美元。可以输出Yes,否则输出No。

我用了字符串匹配 剩下的就是Flyod算法了 并不难

代码AC情况:



代码:
# include <stdio.h>
# define N 30
# define max(a,b) (a)>(b)?(a):(b)
int BF(char A[],char B[]);
int flyd(double map[]
);
double map

,S;
int m,n,i,j,a,b,num=0;
char money

,A
,B
,T[][4]={"No","Yes"};
int main()
{
while(scanf("%d",&n)&&n){
for(i=0;i<n;i++)//初始化
{
for(j=0;j<n;j++)//初始化图
map[i][j]=0;
scanf("%s",&money[i]);//输入钱的名称
}
for(i=0,scanf("%d",&m);i<m;i++)//输入路径
{
scanf("%s%lf%s",A,&S,B);
for(a=b=-1,j=0;a<0||b<0;j++)
{
if(a<0&&BF(A,money[j]))//匹配钱的代号
a=j;
if(b<0&&BF(B,money[j]))
b=j;
}
map[a][b]=S;//将代号压入图
}
printf("Case %d: %s\n",++num,T[flyd(map)]);//输出
}
return 0;
}
int flyd(double map[]
)//floyd算法
{
int i,j,k,F=0;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
for(k=0;k<n;k++)
map[j][k]=max(map[j][k],map[j][i]*map[i][k]);
if(map[i][i]>1)
F=1;
}
return F;
}
int BF(char A[],char B[]){//字符串匹配  若A中含有B 返回B在A中的首位置
int i=0,j=0;
while (A[i]&&B[j])
if (A[i++]==B[j]) ++j;   // 继续比较后继字
else{
i-=j;
j=0;
}
return B[j]?0:i-j+1;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: