您的位置:首页 > 其它

HDU 1037 Keep on Truckin' (水题)

2017-09-05 21:01 363 查看


Keep on Truckin'

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15128    Accepted Submission(s): 10416


Problem Description

Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

 

Input

Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

 

Output

There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler). 

The height of the 18-wheeler is 168 inches.

 

Sample Input

180 160 170

 

Sample Output

CRASH 160

 

Source

South Central USA 2003

题目大意:有一辆卡车高为168,现有三个桥洞,输入桥洞高度,求是否能通过;三个桥洞都高于168则输出NO CRASH,否则输出CRASH “第一个低于168的高度”。

可以说是非常水的题目了。。。只要能看懂题目就能写出来的那种水题;

不过discuss里面有一个神解,我附在下面了,只能说这题的测试数据可能有问题。

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
int main(){
int a,b,c;
while(~scanf("%d%d%d",&a,&b,&c)){
if(a>168&&b>168&&c>168){
printf("NO CRASH\n");
continue;
}
if(a<=168)
printf("CRASH %d\n",a);
else if(b<=168)
printf("CRASH %d\n",b);
else if(c<=168)
printf("CRASH %d\n",c);
}
return 0;
}

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
int main(){
printf("CRASH 167\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: