您的位置:首页 > 其它

HDU 4355 Party All the Time(三分精度问题精度低WA 精度高TLE)

2017-09-05 15:44 471 查看
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long
way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 

Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N).
The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )

Output

For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

Sample Input

1

4

0.6 5

3.9 10

5.1 7

8.4 10

Sample Output
Case #1: 832

题意:给定x轴上有n个点,每一个点都有一个权值,让在x轴上选一个点,求出各点到这个点的距离的三次方乘以权值最小

思路:

三分:x轴上的点(这个点肯定是在n个点所构成的长度之内)

构造函数:因为所求的是最小值,所以a>0,为凸函数.

循环过程有2种,一种是给定一定的次数进行循环,另一种是判断左右节点的差值几乎为0(其本质上都是为了不断缩小范围)

一定次数的循环:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double INF=1<<30;
const int MAX=50005;
const double eps=1e-3;
double x[MAX],w[MAX],c[MAX];
int n;
double cal(double pos)//计算函数值
{
double ans=0;
for(int i=1;i<=n;i++)
ans+=(double)pow(fabs(pos-x[i]),3)*w[i];
return ans;
}
double solve(double l,double r)
{
double mid1,mid2;
for(int i=1;i<30;i++)
{
mid1=(l+r)/2;
mid2=(mid1+r)/2;
if(cal(mid1)>=cal(mid2))
l=mid1;
else
r=mid2;
}
return cal(l);
}

int main()
{
int icase,t=1;
scanf("%d",&icase);
while(icase--)
{
scanf("%d",&n);
double left=1e7,right=-1e7;
for(int i=1;i<=n;i++)
{
scanf("%lf%lf",&x[i],&w[i]);
left=min(left,x[i]);
right=max(right,x[i]);
}
printf("Case #%d: %.0f\n",t++,solve(left,right));
}
}


精度:1e-3的时候WA,1e-8的时候TLE:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double INF=1<<30;
const int MAX=50005;
const double eps=1e-4;
double x[MAX],w[MAX],c[MAX];
int n;
double cal(double pos)//计算函数值
{
double ans=0;
for(int i=1;i<=n;i++)
ans+=(double)pow(fabs(pos-x[i]),3)*w[i];
return ans;
}
double solve(double l,double r)
{
double mid1,mid2;
while(r-l>eps)    //不断比较找最小
{
mid1=(l+r)/2;
mid2=(mid1+r)/2;
if(cal(mid1)>=cal(mid2))
l=mid1;
else
r=mid2;
}
return cal(l);
}

int main()
{
int icase,t=1;
scanf("%d",&icase);
while(icase--)
{
scanf("%d",&n);
double left=1e7,right=-1e7;
for(int i=1;i<=n;i++)
{
scanf("%lf%lf",&x[i],&w[i]);
left=min(left,x[i]);
right=max(right,x[i]);
}
printf("Case #%d: %.0f\n",t++,solve(left,right));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  三分法