您的位置:首页 > 产品设计 > UI/UE

K - The Unique MST(Kruskal判断最小生成树是否唯一)

2017-09-04 22:02 513 查看
Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.


Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2


Sample Output

3
Not Unique!


判断最小生成树是否唯一, 对构造好的图进行一次MST,然后依次去除MST中权值相同的边,再进行一次MST,如果两次最小权值和相同,则MST不唯一

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
struct node
{
int u, v, w;
bool used, del, equ;//是否访问过,删除的边,相等的边
}t[121212];
int pre[121212];//记录父节点
int n, m;
bool flag;
int root(int a)//寻找父节点
{
if(pre[a]==a)
return a;
return pre[a] = root(pre[a]);
}
bool cmp(struct node a, struct node b)//快排
{
return a.w < b.w;
}
int kruskal()//最小生成树
{
int sum = 0;
int k = n;
for(int i=0;i<300;i++)
{
pre[i] = i;
}
for(int i=0;i<m&&k>1;i++)
{
if(t[i].del)//边是否被删除
continue;
if(root(t[i].u)!=root(t[i].v))
{
pre[root(t[i].v)] = root(t[i].u);
sum += t[i].w;
if(flag)
t[i].used = true;
k--;
}
}
return sum;
}
int main()
{
int T, u, v, w;
cin>>T;
while(T--)
{
cin>>n>>m;
for(int i=0;i<m;i++)
{
cin>>u>>v>>w;
t[i].u = u - 1;//从0开始
t[i].v = v - 1;
t[i].w = w;
t[i].used = t[i].del = t[i].equ = false;
}
for(int i=0;i<m;i++)
{
for(int j=0;j<m;j++)
{
if(i==j)
continue;
else if(t[i].w==t[j].w)
t[i].equ = true;//有相同权值的边
}
}
sort(t, t + m, cmp);//快排
flag = true;
int num1 = kruskal(), num2;//分别记录两次的权值
flag = false;
bool flag1 = true;//记录是否唯一
for(int i=0;i<m;i++)
{
if(t[i].used&&t[i].equ)
{
t[i].del = true;//删除此边
num2 = kruskal();
if(num1==num2)//权值相等,不唯一
{
cout<<"Not Unique!"<<endl;
flag1 = false;
break;
}
t[i].del = false;//恢复此边
}
}
if(flag1)
cout<<num1<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kruskal