您的位置:首页 > 其它

A Dangerous Maze LightOJ - 1027 期望

2017-09-04 10:16 453 查看
You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in
xi minutes, or can take you out of the maze after
xi
minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains
n space separated integers. If the ith integer
(xi) is positive, you can assume that the ith door will take you out of maze after
xi minutes. If it's negative, then the ith door will take you back to the beginning position after
abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output
For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print
'inf'. Print the result in p/q format. Where
p
is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input
3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output
Case 1: 1/1

Case 2: inf

Case 3: 18/1

思路:
如果想要出去分两种情况

1.直接走代价为正数的门直接出去

2.走代价为负数的门然后再通过决策决定如何出去

我们设走出去的期望时间为E,选择正代价的门的概率为p1,正代价出门的平均代价为T1,选择负代价的门的概率为p2,负代价出门的平均代价为T2

所以我们可以得到方程E=p1*T1+p2*(T2+E)

解得E=所有数绝对值的和/正数的个数

#include<bits/stdc++.h>
using namespace std;
int gcd(int x,int y)
{
return y?gcd(y,x%y):x;
}
int main()
{
int t,kase=1;
scanf("%d",&t);
while(t--)
{
int temp;
int n;
int zheng=0;
int sum=0;
scanf("%d",&n);
for(int i=0; i<n; i++)
{
scanf("%d",&temp);
sum+=abs(temp);
if(temp>0)
zheng++;
}
printf("Case %d: ", kase++);
if (zheng==0)
{
printf("inf\n");
continue;
}
int s=gcd(sum,zheng);
printf("%d/%d\n",sum/s,zheng/s);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: