您的位置:首页 > 其它

1066: 字符分类统计

2017-09-03 19:05 323 查看

1066: 字符分类统计

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 10446  Solved: 5614

SubmitStatusWeb
Board

Description

输入一行字符,以回车符作为输入结束的标志。统计其中英文字母、数字字符和其他字符的个数。

Input

多个字符,以回车符结束,回车符不作为有效字符。有效字符个数不超过100。

Output

输出分3行,格式见输出样例。

Sample Input

Abse 4+5*3=?

Sample Output

letter:4digit:3other:5

HINT

Source

*

#include<stdio.h>

int main()
{
int l,d,o;
char ch;
l=0;
d=0;
o=0;

while(scanf("%c",&ch), ch!='\n')
{
if((ch>='a'&&ch<='z')||(ch>='A'&&ch<='Z'))
l=l+1;
else if(ch>='0'&&ch<='9')
d=d+1;
else
o=o+1;

}
printf("letter:%d\ndigit:%d\nother:%d\n",l,d,o);
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: